summaryrefslogtreecommitdiff
path: root/dev-python/arpeggio
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/arpeggio')
-rw-r--r--dev-python/arpeggio/Manifest2
-rw-r--r--dev-python/arpeggio/arpeggio-1.9.0.ebuild34
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/arpeggio/Manifest b/dev-python/arpeggio/Manifest
index b2d96ff9b521..536cc45e465c 100644
--- a/dev-python/arpeggio/Manifest
+++ b/dev-python/arpeggio/Manifest
@@ -1,3 +1,5 @@
DIST Arpeggio-1.5.tar.gz 18856 BLAKE2B 5ceb26d034622c448ea29adc70f6934dc2de8335c526f02d91bc4bccaf435d462516830fa6b124638fdcb0b4aadc859d602e1ec59469077d796b7534fa28f7aa SHA512 533c59635556a3446c04c8b14f53e8ad6a7a39869f39d958bdd52b5a55ad43c533bc42a41999cc149015b34470d8ff0eca295ff1942c75b33a58a403a604c449
+DIST arpeggio-1.9.0.tar.gz 757412 BLAKE2B f89850a16b2ac1a87cbac3ae0f10d4c04af6097bfb9292abec24c8b938bdf3b837c4d292650b2e335ee5b4b03cd149e1722e35ceabf1b59fd4577ba7e62a8e44 SHA512 179ec76813476823f316471e1b313f377064a75879c52060e547fd755ae72947594dc4d6e58a798150620e82c8b123fbd88484881c12ccb311c47bc93a45a0cd
EBUILD arpeggio-1.5.ebuild 717 BLAKE2B 93d76df94ee12e3e3bb7f8dca73cf6e8fa8f313c0debd16fed3bfa1835462842e3a0f4d44bd48e2e09cfb12c9efdbb61087fb32bbfa372f1fa0cc9ae493a7a94 SHA512 5c17a9079285ec2a1a2c0f943f221a6262e1f09198db2f4838548e36dbf0295e3027104e4b07df3e3dfdc460164ef05896a05c986a9c17886dfa8eaebb8ff8b4
+EBUILD arpeggio-1.9.0.ebuild 772 BLAKE2B 3337d5012d3f32498090a9b54f21d84c575cab1d349781324faebce872cfcaf8ae369aa9f38fd618d7b1ef04bd9a9bf9e058936d60cc39fef5d1ddf7a1d2aef1 SHA512 41b609617e325efc45ad0c4b4ffa56408db1ebaefa1f0c2fdf4f26c305548d6f9ea334003cfbf24422e0b1a9d3d1af40cfed5b9b4dba74b0c61ea7bb858c9da2
MISC metadata.xml 351 BLAKE2B dac9aebd47c197ac00e60de049d4bfc62b3fc4082e1566475ca0a9fba0435385dc475cb6c2e7eaa6e4b91ea0ccb097ebe55da23f5f3e00325c7c1fc74e66d278 SHA512 cad3a1cb94dacf951a07d5a98a35bd723b00ba6745f52f1ff2f5d20c5c63fa9c1e875617a0833f822a1177cba0805b07964eb6ca0abbfa74f93dcd42f601a935
diff --git a/dev-python/arpeggio/arpeggio-1.9.0.ebuild b/dev-python/arpeggio/arpeggio-1.9.0.ebuild
new file mode 100644
index 000000000000..77211f6a5609
--- /dev/null
+++ b/dev-python/arpeggio/arpeggio-1.9.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} )
+
+inherit distutils-r1
+
+MY_PN=Arpeggio
+MY_P=${MY_PN}-${PV}
+DESCRIPTION="Parser interpreter based on PEG grammars"
+HOMEPAGE="https://pypi.org/project/Arpeggio/ https://github.com/igordejanovic/Arpeggio"
+SRC_URI="https://github.com/igordejanovic/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND=""
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/memory_profiler[${PYTHON_USEDEP}]
+ )
+"
+S=${WORKDIR}/${MY_P}
+
+python_test() {
+ pytest -vv || die "Testing failed"
+}