summaryrefslogtreecommitdiff
path: root/dev-python/argon2-cffi/argon2-cffi-23.1.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/argon2-cffi/argon2-cffi-23.1.0.ebuild')
-rw-r--r--dev-python/argon2-cffi/argon2-cffi-23.1.0.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/argon2-cffi/argon2-cffi-23.1.0.ebuild b/dev-python/argon2-cffi/argon2-cffi-23.1.0.ebuild
new file mode 100644
index 000000000000..0767a88987da
--- /dev/null
+++ b/dev-python/argon2-cffi/argon2-cffi-23.1.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="CFFI bindings to the Argon2 password hashing library"
+HOMEPAGE="
+ https://github.com/hynek/argon2-cffi/
+ https://pypi.org/project/argon2-cffi/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/argon2-cffi-bindings-21.2.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/hatch-fancy-pypi-readme[${PYTHON_USEDEP}]
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
+ test? (
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest