summaryrefslogtreecommitdiff
path: root/dev-python/apsw/apsw-3.45.1.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/apsw/apsw-3.45.1.0.ebuild')
-rw-r--r--dev-python/apsw/apsw-3.45.1.0.ebuild51
1 files changed, 0 insertions, 51 deletions
diff --git a/dev-python/apsw/apsw-3.45.1.0.ebuild b/dev-python/apsw/apsw-3.45.1.0.ebuild
deleted file mode 100644
index 617cadf72867..000000000000
--- a/dev-python/apsw/apsw-3.45.1.0.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_EXT=1
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..12} )
-
-inherit distutils-r1
-
-DESCRIPTION="APSW - Another Python SQLite Wrapper"
-HOMEPAGE="
- https://github.com/rogerbinns/apsw/
- https://pypi.org/project/apsw/
-"
-SRC_URI="
- https://github.com/rogerbinns/apsw/archive/${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="ZLIB"
-SLOT="0"
-KEYWORDS="amd64 ~arm arm64 ~ppc64 x86"
-IUSE="doc"
-
-DEPEND="
- >=dev-db/sqlite-${PV%.*}:3
-"
-RDEPEND="
- ${DEPEND}
-"
-
-src_configure() {
- cat >> setup.cfg <<-EOF || die
- [build_ext]
- enable=load_extension
- use_system_sqlite_config=True
- EOF
-}
-
-python_test() {
- esetup.py build_test_extension
- cd "${T}" || die
- "${EPYTHON}" -m apsw.tests -v || die "Tests failed under ${EPYTHON}"
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( doc/. )
- distutils-r1_python_install_all
-}