summaryrefslogtreecommitdiff
path: root/dev-python/apse/apse-0.2-r3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/apse/apse-0.2-r3.ebuild')
-rw-r--r--dev-python/apse/apse-0.2-r3.ebuild40
1 files changed, 0 insertions, 40 deletions
diff --git a/dev-python/apse/apse-0.2-r3.ebuild b/dev-python/apse/apse-0.2-r3.ebuild
deleted file mode 100644
index a2843e778096..000000000000
--- a/dev-python/apse/apse-0.2-r3.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-PYTHON_COMPAT=( python2_7 pypy )
-
-inherit distutils-r1
-
-MY_P="Apse-${PV}"
-
-DESCRIPTION="Approximate String Matching in Python"
-HOMEPAGE="https://wiki.gentoo.org/wiki/No_homepage"
-SRC_URI="http://www.personal.psu.edu/staff/i/u/iua1/python/${PN}/dist/${MY_P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ia64 ppc ppc64 x86"
-IUSE=""
-
-RDEPEND=""
-DEPEND="dev-lang/swig:1"
-
-S="${WORKDIR}/${MY_P}"
-
-python_prepare_all() {
- # Prevent the build system from calling swig over and over again.
- sed -i -e 's:Apse.i:Apse_wrap.c:' setup.py || die
-
- distutils-r1_python_prepare_all
-}
-
-python_configure_all() {
- set -- swig1.3 -python -o Apse_wrap.c Apse.i
- echo "${@}" >&2
- "${@}" || die
-}
-
-python_test() {
- "${PYTHON}" test/test_Apse.py || die "Tests fail with ${EPYTHON}"
-}