summaryrefslogtreecommitdiff
path: root/dev-python/apprise/apprise-1.7.4.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/apprise/apprise-1.7.4.ebuild')
-rw-r--r--dev-python/apprise/apprise-1.7.4.ebuild38
1 files changed, 0 insertions, 38 deletions
diff --git a/dev-python/apprise/apprise-1.7.4.ebuild b/dev-python/apprise/apprise-1.7.4.ebuild
deleted file mode 100644
index 4f6bb4ff272e..000000000000
--- a/dev-python/apprise/apprise-1.7.4.ebuild
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..12} )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="Push Notifications that work with just about every platform"
-HOMEPAGE="
- https://pypi.org/project/apprise/
- https://github.com/caronc/apprise/
-"
-
-LICENSE="BSD-2"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 ~riscv"
-IUSE="+dbus mqtt"
-
-RDEPEND="
- dev-python/click[${PYTHON_USEDEP}]
- dev-python/markdown[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- dev-python/requests-oauthlib[${PYTHON_USEDEP}]
- dev-python/pyyaml[${PYTHON_USEDEP}]
- dbus? ( dev-python/dbus-python[${PYTHON_USEDEP}] )
- mqtt? ( dev-python/paho-mqtt[${PYTHON_USEDEP}] )
-"
-BDEPEND="
- dev-python/Babel[${PYTHON_USEDEP}]
- test? (
- dev-python/pytest-mock[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest