summaryrefslogtreecommitdiff
path: root/dev-python/apipkg/apipkg-3.0.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/apipkg/apipkg-3.0.2.ebuild')
-rw-r--r--dev-python/apipkg/apipkg-3.0.2.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/apipkg/apipkg-3.0.2.ebuild b/dev-python/apipkg/apipkg-3.0.2.ebuild
new file mode 100644
index 000000000000..eb4e82049ad9
--- /dev/null
+++ b/dev-python/apipkg/apipkg-3.0.2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1
+
+MY_P=${P/_/}
+DESCRIPTION="Namespace control and lazy-import mechanism"
+HOMEPAGE="
+ https://github.com/pytest-dev/apipkg/
+ https://pypi.org/project/apipkg/
+"
+SRC_URI="
+ https://github.com/pytest-dev/apipkg/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+BDEPEND="
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}