summaryrefslogtreecommitdiff
path: root/dev-python/anyio
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/anyio')
-rw-r--r--dev-python/anyio/Manifest4
-rw-r--r--dev-python/anyio/anyio-4.2.0.ebuild61
-rw-r--r--dev-python/anyio/anyio-4.3.0.ebuild2
3 files changed, 2 insertions, 65 deletions
diff --git a/dev-python/anyio/Manifest b/dev-python/anyio/Manifest
index 298499e6233f..640497cbb3e2 100644
--- a/dev-python/anyio/Manifest
+++ b/dev-python/anyio/Manifest
@@ -1,5 +1,3 @@
-DIST anyio-4.2.0.tar.gz 158770 BLAKE2B 10ae621872edb27727c8931904c84f41dc18ef0cc4cce1ea18c957d479be24b1a4ffb15d8a9e2b4338663fdbc2a989e5772ba1bd2076f9f0b22f6f5c4feef4bc SHA512 a6f3cbedbfa063a5cf031cd833e6da7a23ee37dbdae8d47ccdfb09c61a73c186267f1a33ba6b4936cac7fb4c970f5488ff1464295e5ffa452952732ac0468d65
DIST anyio-4.3.0.tar.gz 159642 BLAKE2B 33b300d1da37137d45b311f8424c022d19518c207c39ec6f8bd3e42432cf1457f2d533eadeaa1e21853ed1b25a4f58818fc595e8588489722846f8a8d72262dc SHA512 26ff552a03b24b63c7c99cffcec61e97289eacba3ad2fc7a3c1dde8cfaffd9a8d621b867429901c12d7cef912d3807db134dbeb9c5ba619921160f6d5df4d02f
-EBUILD anyio-4.2.0.ebuild 1684 BLAKE2B 82452731d1288270c4d6229f5a8aedf5e930f292ad4df17e145fa4239390dc9172623fa33c464893bc371c74023c7ffe7fc1e6801a4cbd09872ab6c3def463c8 SHA512 478925f2d70e8c5130f75a2650da30b5c8e772a79d25d2dc73d5eafb4d9ad6e8afaa23d94074993d14b1928b0aefd53fc6fc8840363a2ec514142a83f5c9039d
-EBUILD anyio-4.3.0.ebuild 1692 BLAKE2B 4717758a6e86e9ae8ee11ec3d51de1af31e91bcc6a313160026924bbb9be22c973ee2d9084e38dc8a6ed2dd5a6cf6a000860df07d6b0dcdd0ef9dbbd402e46f4 SHA512 c6ef93b1e08b2d662935a6347e6bdba9b553fedf74869b12c278875bee44272b6ecbc168a016e88a3b851d6b0294f17e3ec311fc07a409ba09d00dcf70e7cd9d
+EBUILD anyio-4.3.0.ebuild 1684 BLAKE2B 82452731d1288270c4d6229f5a8aedf5e930f292ad4df17e145fa4239390dc9172623fa33c464893bc371c74023c7ffe7fc1e6801a4cbd09872ab6c3def463c8 SHA512 478925f2d70e8c5130f75a2650da30b5c8e772a79d25d2dc73d5eafb4d9ad6e8afaa23d94074993d14b1928b0aefd53fc6fc8840363a2ec514142a83f5c9039d
MISC metadata.xml 1422 BLAKE2B 63acae587e7088e33ee5eb93a2a222899e54a5eb511118794f88e7c5a012d10983eb925427688a0b509b094e30a9cc9acc5f0c1765ea73e569161e0c30722000 SHA512 e0b540d5d739b7673a5a8682477f209f8b3648aad06a1c0610543a2e9dcbeca1cb1e52212d8088a5987a1c3bc3152cc5984ad5b5d0706fcdb5866b22de07b1eb
diff --git a/dev-python/anyio/anyio-4.2.0.ebuild b/dev-python/anyio/anyio-4.2.0.ebuild
deleted file mode 100644
index 4768f8c60a52..000000000000
--- a/dev-python/anyio/anyio-4.2.0.ebuild
+++ /dev/null
@@ -1,61 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( pypy3 python3_{10..12} )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="Compatibility layer for multiple asynchronous event loop implementations"
-HOMEPAGE="
- https://github.com/agronholm/anyio/
- https://pypi.org/project/anyio/
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~mips ppc ppc64 ~riscv ~s390 sparc x86"
-
-RDEPEND="
- >=dev-python/exceptiongroup-1.2.0[${PYTHON_USEDEP}]
- >=dev-python/idna-2.8[${PYTHON_USEDEP}]
- >=dev-python/sniffio-1.1[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '
- >=dev-python/typing-extensions-4.1[${PYTHON_USEDEP}]
- ' 3.10)
-"
-# On amd64, let's get more test coverage by dragging in uvloop, but let's
-# not bother on other arches where uvloop may not be supported.
-BDEPEND="
- >=dev-python/setuptools-scm-6.4[${PYTHON_USEDEP}]
- test? (
- >=dev-python/hypothesis-4.0[${PYTHON_USEDEP}]
- >=dev-python/psutil-5.9[${PYTHON_USEDEP}]
- >=dev-python/pytest-mock-3.6.1[${PYTHON_USEDEP}]
- >=dev-python/trio-0.23[${PYTHON_USEDEP}]
- dev-python/trustme[${PYTHON_USEDEP}]
- amd64? (
- $(python_gen_cond_dep '
- >=dev-python/uvloop-0.17[${PYTHON_USEDEP}]
- ' python3_{10..12})
- )
- )
-"
-
-distutils_enable_tests pytest
-distutils_enable_sphinx docs \
- '>=dev-python/sphinx-rtd-theme-1.2.2' \
- dev-python/sphinxcontrib-jquery \
- dev-python/sphinx-autodoc-typehints
-
-python_test() {
- local EPYTEST_DESELECT=(
- # requires link-local IPv6 interface
- tests/test_sockets.py::TestTCPListener::test_bind_link_local
- )
-
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- epytest -m 'not network'
-}
diff --git a/dev-python/anyio/anyio-4.3.0.ebuild b/dev-python/anyio/anyio-4.3.0.ebuild
index 694cd3be7f30..4768f8c60a52 100644
--- a/dev-python/anyio/anyio-4.3.0.ebuild
+++ b/dev-python/anyio/anyio-4.3.0.ebuild
@@ -16,7 +16,7 @@ HOMEPAGE="
LICENSE="MIT"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~mips ppc ppc64 ~riscv ~s390 sparc x86"
RDEPEND="
>=dev-python/exceptiongroup-1.2.0[${PYTHON_USEDEP}]