summaryrefslogtreecommitdiff
path: root/dev-python/anyio
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/anyio')
-rw-r--r--dev-python/anyio/Manifest1
-rw-r--r--dev-python/anyio/anyio-4.3.0-r1.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/dev-python/anyio/Manifest b/dev-python/anyio/Manifest
index 640497cbb3e2..2c522ca69b96 100644
--- a/dev-python/anyio/Manifest
+++ b/dev-python/anyio/Manifest
@@ -1,3 +1,4 @@
DIST anyio-4.3.0.tar.gz 159642 BLAKE2B 33b300d1da37137d45b311f8424c022d19518c207c39ec6f8bd3e42432cf1457f2d533eadeaa1e21853ed1b25a4f58818fc595e8588489722846f8a8d72262dc SHA512 26ff552a03b24b63c7c99cffcec61e97289eacba3ad2fc7a3c1dde8cfaffd9a8d621b867429901c12d7cef912d3807db134dbeb9c5ba619921160f6d5df4d02f
+EBUILD anyio-4.3.0-r1.ebuild 1747 BLAKE2B f774bbc2caf5d31511b117c16a0cf2daffcd1109dd1ca6a87dda2c4c3bf55d48fc3cb4db57d192956cd887bbcffde324e6f177d7ce1539ed969a1dd9c094c199 SHA512 479ccf1860356a8264ca3aa600ce7ab959959ee98b282db41237c1a3c11acbf57eb56f29bcd81d3b5ba7682a5683d2ab9bd630a5769291b3211a1e04e918cb18
EBUILD anyio-4.3.0.ebuild 1684 BLAKE2B 82452731d1288270c4d6229f5a8aedf5e930f292ad4df17e145fa4239390dc9172623fa33c464893bc371c74023c7ffe7fc1e6801a4cbd09872ab6c3def463c8 SHA512 478925f2d70e8c5130f75a2650da30b5c8e772a79d25d2dc73d5eafb4d9ad6e8afaa23d94074993d14b1928b0aefd53fc6fc8840363a2ec514142a83f5c9039d
MISC metadata.xml 1422 BLAKE2B 63acae587e7088e33ee5eb93a2a222899e54a5eb511118794f88e7c5a012d10983eb925427688a0b509b094e30a9cc9acc5f0c1765ea73e569161e0c30722000 SHA512 e0b540d5d739b7673a5a8682477f209f8b3648aad06a1c0610543a2e9dcbeca1cb1e52212d8088a5987a1c3bc3152cc5984ad5b5d0706fcdb5866b22de07b1eb
diff --git a/dev-python/anyio/anyio-4.3.0-r1.ebuild b/dev-python/anyio/anyio-4.3.0-r1.ebuild
new file mode 100644
index 000000000000..5636aa635281
--- /dev/null
+++ b/dev-python/anyio/anyio-4.3.0-r1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Compatibility layer for multiple asynchronous event loop implementations"
+HOMEPAGE="
+ https://github.com/agronholm/anyio/
+ https://pypi.org/project/anyio/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/idna-2.8[${PYTHON_USEDEP}]
+ >=dev-python/sniffio-1.1[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/exceptiongroup-1.2.0[${PYTHON_USEDEP}]
+ >=dev-python/typing-extensions-4.1[${PYTHON_USEDEP}]
+ ' 3.10)
+"
+# On amd64, let's get more test coverage by dragging in uvloop, but let's
+# not bother on other arches where uvloop may not be supported.
+BDEPEND="
+ >=dev-python/setuptools-scm-6.4[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/exceptiongroup-1.2.0[${PYTHON_USEDEP}]
+ >=dev-python/hypothesis-4.0[${PYTHON_USEDEP}]
+ >=dev-python/psutil-5.9[${PYTHON_USEDEP}]
+ >=dev-python/pytest-mock-3.6.1[${PYTHON_USEDEP}]
+ >=dev-python/trio-0.23[${PYTHON_USEDEP}]
+ dev-python/trustme[${PYTHON_USEDEP}]
+ amd64? (
+ $(python_gen_cond_dep '
+ >=dev-python/uvloop-0.17[${PYTHON_USEDEP}]
+ ' python3_{10..12})
+ )
+ )
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs \
+ '>=dev-python/sphinx-rtd-theme-1.2.2' \
+ dev-python/sphinxcontrib-jquery \
+ dev-python/sphinx-autodoc-typehints
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # requires link-local IPv6 interface
+ tests/test_sockets.py::TestTCPListener::test_bind_link_local
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -m 'not network'
+}