summaryrefslogtreecommitdiff
path: root/dev-python/antlr4-python3-runtime/antlr4-python3-runtime-4.10.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/antlr4-python3-runtime/antlr4-python3-runtime-4.10.ebuild')
-rw-r--r--dev-python/antlr4-python3-runtime/antlr4-python3-runtime-4.10.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/antlr4-python3-runtime/antlr4-python3-runtime-4.10.ebuild b/dev-python/antlr4-python3-runtime/antlr4-python3-runtime-4.10.ebuild
new file mode 100644
index 000000000000..93aaa44d8c7c
--- /dev/null
+++ b/dev-python/antlr4-python3-runtime/antlr4-python3-runtime-4.10.ebuild
@@ -0,0 +1,25 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python 3 runtime for ANTLR"
+HOMEPAGE="https://www.antlr.org/"
+SRC_URI="
+ https://github.com/antlr/antlr4/archive/${PV}.tar.gz
+ -> antlr-${PV}.tar.gz
+"
+S="${WORKDIR}/antlr4-${PV}/runtime/Python3"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+python_test() {
+ "${EPYTHON}" tests/run.py -v || die "Tests failed with ${EPYTHON}"
+}