summaryrefslogtreecommitdiff
path: root/dev-python/ansicolor
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/ansicolor')
-rw-r--r--dev-python/ansicolor/Manifest4
-rw-r--r--dev-python/ansicolor/ansicolor-0.3.2.ebuild20
-rw-r--r--dev-python/ansicolor/metadata.xml4
3 files changed, 27 insertions, 1 deletions
diff --git a/dev-python/ansicolor/Manifest b/dev-python/ansicolor/Manifest
index 58ae2d2b5755..c7226fcb6798 100644
--- a/dev-python/ansicolor/Manifest
+++ b/dev-python/ansicolor/Manifest
@@ -1,4 +1,6 @@
DIST ansicolor-0.2.6.tar.gz 6224 BLAKE2B 38ffd0e9a88c886ebad25c4f0072f2f8f833e028c3bc14eb89252c1c0b501f973c9b3e371b4c605a3b98df33eb7203a963797d3ee56cf87b0afb927b19096fd5 SHA512 44c7dc6f621fc3044d4a52acb96e7e497578e025090633bfc8cbf686d7461da018f64502b477a6090e60747481f320cebaad00ee0776c9f4c52d4abbb1812121
+DIST ansicolor-0.3.2.gh.tar.gz 118221 BLAKE2B f3f621298858974522dd05665c66ffebfc335291b61c6f0e6f835aaddf099559412f12979ad2a43001690b430125c8e1a8fd5427ad3268393d75bd736353d598 SHA512 de1e1bc9d8a02accaa57a64e5d2ea1f510545b3ab83218c47c7a1861e8438862c222147c9dcab0fcb1ec4055dcee07d6cde6d7bfecfbf9ac55c3bb76ac0fb0ab
EBUILD ansicolor-0.2.6-r1.ebuild 705 BLAKE2B 947fee39b97c8d54cd417a6a0dd7f49c23f9cb85f3c60f9abb2ee14915a5e097353bc848db31a6da73a7dec9d2b500c8ab127d185169bc69522307b449e9292f SHA512 758eac8f5f525bc8999a0306404d5b276c2db89591f6515cf1801524b8e798adec081f0de7e0024eca1857ad95d7572b3f4b5eb395650fd5573ef261624c4ed4
+EBUILD ansicolor-0.3.2.ebuild 509 BLAKE2B 879325f2e1ec8f4f33b24553ac5f73f3fa182f2d2937b494e439ac1ed835ebfd55db192cec0ba7116f22ba2ef09a73121e6273b3aaad1ad38cfe75948aca7fad SHA512 37caee11f10bb3b990d6956f53030ad5a1bfc8d1473b649f6994ad6c7bfd354667535b453cb285f2fae885a492cadbd0e1bfba499e52bd5536c1f768323cfb4e
EBUILD ansicolor-9999.ebuild 707 BLAKE2B cb535dffd18e59e94fe635d7910856496ba16404decc460e17cd5c147cf40858c2dbae20d97aa9724d25b6f2c4d35ab84e1c219474994e876ee2f93f7d73fdc0 SHA512 6b8c4bc62878bffd9c6198ca67c5f5828ee7c40f401e8484783992e4a534462f8f3c0ec1166ddcf0cf219273e8fa3d816b9d96214c06e12ec57fe88da47f0ca9
-MISC metadata.xml 549 BLAKE2B 0f0c2290e8418d5ad42ea30e721735ae1201f3c6e0c493d42def746a4f0db7f099079cdfc564e8c0efec8c8e1e89c1f5f2c169e29beb5629fc80167ff2e3e946 SHA512 88ecdaa27c61a59062d0fbf0fab3fb2140f90787919fcf4fb1f87b7cc9b73fc071da03c92412b666661af2be6f23601fa6ff5f9fd7c8bf7e0f1bf6533115c81e
+MISC metadata.xml 650 BLAKE2B 05b096ef57e74cf06badce53c95477473a04e8c3b78944b9fbd9754d86434130632f8fb25dc85fba856bccff83bb8bcf81cfa356088830ee5cddc6d9d71cc7e7 SHA512 0bc8789fe7c349f8a2c0ba557773372704ef0347ef5218ab8feb98e64ca05951b900ebe015561d89a49c69bdd341fd468599767fa65422363e90e89b34ba7863
diff --git a/dev-python/ansicolor/ansicolor-0.3.2.ebuild b/dev-python/ansicolor/ansicolor-0.3.2.ebuild
new file mode 100644
index 000000000000..510a58e663bc
--- /dev/null
+++ b/dev-python/ansicolor/ansicolor-0.3.2.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Produce ansi color output and colored highlighting and diffing"
+HOMEPAGE="https://github.com/numerodix/ansicolor https://pypi.org/project/ansicolor/"
+SRC_URI="
+ https://github.com/numerodix/ansicolor/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+distutils_enable_tests pytest
diff --git a/dev-python/ansicolor/metadata.xml b/dev-python/ansicolor/metadata.xml
index dbbdd0271494..6bf299c1b80e 100644
--- a/dev-python/ansicolor/metadata.xml
+++ b/dev-python/ansicolor/metadata.xml
@@ -9,6 +9,10 @@
<email>proxy-maint@gentoo.org</email>
<name>Proxy Maintainers</name>
</maintainer>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
<stabilize-allarches/>
<upstream>
<remote-id type="github">numerodix/ansicolor</remote-id>