summaryrefslogtreecommitdiff
path: root/dev-python/alembic/alembic-1.13.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/alembic/alembic-1.13.1.ebuild')
-rw-r--r--dev-python/alembic/alembic-1.13.1.ebuild5
1 files changed, 5 insertions, 0 deletions
diff --git a/dev-python/alembic/alembic-1.13.1.ebuild b/dev-python/alembic/alembic-1.13.1.ebuild
index d30bacd5aaea..e8a5a9d46409 100644
--- a/dev-python/alembic/alembic-1.13.1.ebuild
+++ b/dev-python/alembic/alembic-1.13.1.ebuild
@@ -34,6 +34,11 @@ BDEPEND="
EPYTEST_XDIST=1
distutils_enable_tests pytest
+PATCHES=(
+ # https://github.com/sqlalchemy/alembic/commit/6bdb9043868d4bd04ebe3fe8a4991735d5f87ed3
+ "${FILESDIR}/${P}-pytest-8.patch"
+)
+
python_test() {
local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
# setup.cfg contains -p no:warnings in addopts which triggers