summaryrefslogtreecommitdiff
path: root/dev-python/aiosmtpd
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/aiosmtpd')
-rw-r--r--dev-python/aiosmtpd/Manifest3
-rw-r--r--dev-python/aiosmtpd/aiosmtpd-1.4.5.ebuild36
-rw-r--r--dev-python/aiosmtpd/metadata.xml13
3 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/aiosmtpd/Manifest b/dev-python/aiosmtpd/Manifest
new file mode 100644
index 000000000000..569387f0be85
--- /dev/null
+++ b/dev-python/aiosmtpd/Manifest
@@ -0,0 +1,3 @@
+DIST aiosmtpd-1.4.5.tar.gz 152668 BLAKE2B 5f689e029afcc267b8b9f1863ce20d76bea16985d7fddac1e6cf0624d7bef6bbbe7089b4933bee8b5aaa74e63d996295e3684b3a7891b697608cbd311be92728 SHA512 c9507e25b5aeec442d299e13624ce00777ecf8089eee230b9cb9f92c18816cef890968c25144a56b95fd9b063b1440921841a16add624d717b8f6378d55c85a4
+EBUILD aiosmtpd-1.4.5.ebuild 757 BLAKE2B d161310f3e7788538776f9322369a8fe8522c7ccfa4bccdd28076e9fdcebecdfb3ee3b88a3d1166ef776b996f7ec013869003907e06435d901ec71a469a652f0 SHA512 b6d89e9974e0ed5cfb9414fac0e80e494ba2f47b831f0ce2b6c4bfd6fe88f9e2c7cf8621db1e93a8fd3acf5722034ccda198cd4c8fae7f4e54b9ca58b6907aa3
+MISC metadata.xml 406 BLAKE2B cd739d7ad278ddd958ea696ec4ed98c44a4a5cf719b93b09eeb7aae4af37e0bc755302d0c27b36645b291071d7ce16e45ef8e77275ef68cdc9f9cc759d2ffb1a SHA512 3f3459da7aa5b686f38b5554a64d0c8344bacab39429a19955b56b3b829f0aaf6fd5e6c337394134ba59c3b2d5b5be1fa1f917775b6827b56f055a8203339ed7
diff --git a/dev-python/aiosmtpd/aiosmtpd-1.4.5.ebuild b/dev-python/aiosmtpd/aiosmtpd-1.4.5.ebuild
new file mode 100644
index 000000000000..49dbf8d58d30
--- /dev/null
+++ b/dev-python/aiosmtpd/aiosmtpd-1.4.5.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Reimplementation of the Python stdlib smtpd.py based on asyncio"
+HOMEPAGE="
+ https://aiosmtpd.aio-libs.org/
+ https://github.com/aio-libs/aiosmtpd
+ https://pypi.org/project/aiosmtpd/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-python/atpublic-4.0[${PYTHON_USEDEP}]
+ >=dev-python/attrs-23.2.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? ( >=dev-python/pytest-mock-3.12.0[${PYTHON_USEDEP}] )
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ sed -i -e '/--cov=/d' pytest.ini || die
+
+ distutils-r1_python_prepare_all
+}
diff --git a/dev-python/aiosmtpd/metadata.xml b/dev-python/aiosmtpd/metadata.xml
new file mode 100644
index 000000000000..850c71fdd27e
--- /dev/null
+++ b/dev-python/aiosmtpd/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="pypi">aiosmtpd</remote-id>
+ <remote-id type="github">aio-libs/aiosmtpd</remote-id>
+ </upstream>
+</pkgmetadata>