summaryrefslogtreecommitdiff
path: root/dev-python/aiohttp
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/aiohttp')
-rw-r--r--dev-python/aiohttp/Manifest2
-rw-r--r--dev-python/aiohttp/aiohttp-3.6.1.ebuild80
2 files changed, 82 insertions, 0 deletions
diff --git a/dev-python/aiohttp/Manifest b/dev-python/aiohttp/Manifest
index d53bc9df7379..7f281650402b 100644
--- a/dev-python/aiohttp/Manifest
+++ b/dev-python/aiohttp/Manifest
@@ -2,7 +2,9 @@ AUX aiohttp-3.0.5-tests.patch 294 BLAKE2B c535d85c0ad73394897db4db2743e3e6c09faa
DIST aiohttp-2.3.10.tar.gz 848324 BLAKE2B c32a7be3f3d9ba0bd1308c5bea779a10e177b9c018a03fb3cf95d1a1392180f3b4ea294dc23e2e946cc1065d16d212a169ec262a79034ae94b3a5067fbaf362c SHA512 e4ea725bbd3d7d749f2ec21eea1ff9f5c836fbeaa17ad72f77e378c69b008448e57503175bee6adff86110f65edc915cb6368df3011d1d9d61cf47718b086be0
DIST aiohttp-3.5.4.tar.gz 1097647 BLAKE2B 27d3631cf33cc5052deecfeca23f6c052fce344d9a889b0c0c0e68d9dcc19eb56e2ef2496f025c795dea4f906a59ae579ecd489188f8c56bc41255b4f450f4bf SHA512 9bc31457029f7db5bbfe1e213c1f428bf90ac96d83b6d2c8838261a3910ab9f7632a4299618377acb1bed04b0cbb4b4f6d9ee814495c05f210ed9bb4f4c61714
DIST aiohttp-3.6.0.tar.gz 1110800 BLAKE2B 30c583c5d9079dcc3481b917b51c09e40572228a2df3acab468036f22a75fbb21963805bc37d353c82cc81fddc6da85e9ae9fa6b4a0eb0c305de5428f48a05b2 SHA512 90a0c55b5f20fc7cc14d138fca93206a7b64ac069fbd81c77b5373985236c0c09b44bd167be58129ce2e4f2bdefe59891d6d52938f9fe04c462d4aea6af67d9d
+DIST aiohttp-3.6.1.tar.gz 1113678 BLAKE2B cfdf1c650ec52c7b6423f7afd40060ccd1631a407f126bf64c2a353c51f09c31bae3912b8ce9397c0c8350a2e82a98724ae58335998d1ab08ae46a49abce0251 SHA512 4939b89d45abcd655ef212ff87f66a83882fb12dffb87d62ae57afcd9517725af61f46f9b7428112e2dcd72d3a4027524967461270ede34348ff3ead47d14c9b
EBUILD aiohttp-2.3.10.ebuild 1716 BLAKE2B a2736bc15b41a4a29bb45ff422b86c30d886fbc80e968bf7b435045addf953bef80e24950e5ab6573e5e84f358f89c59d217e56c717a9e13aa06410f8d5e7a2d SHA512 541325c91470dc74f8f51843c5544efed81ad52bf706a8160f6fb269ae9c594a4c1f86f556b846998667b8996a80dacbc86bad968dbf5824fa81b509f3dc4049
EBUILD aiohttp-3.5.4.ebuild 2194 BLAKE2B 5d8c82f63b0f6aff4f640da121266e99489073653107f912ac224ea78e5c419af40909994fc8d4fd3e825d0acb4c01eee572b6f7ce77088c7a53f2a988eee4a1 SHA512 35012568426f847ba852b26db64dcd3f6d535692bf897c75b822cc33b5b826a1c526f9f300bc3496b38beef7d940c785b3634704f8137d6a8ea1a2af9ff211d1
EBUILD aiohttp-3.6.0.ebuild 2196 BLAKE2B 31e48cd677a296f32f3f8249fedf71d288eaddd62a7c46ead50729662c8c201994ad8cc3544decd04968784ef5a7baa86ff1daaf64b7f996367d0f4276b376f2 SHA512 592685e8a6ff8a6da602dc63659f4c37bc522ac5be1c7aa8edb6be96d224f57c41e6ea7dca9c462b5c4662a4a1db342ae5db38b1b6b7ac5d04ca3d7ba05873b1
+EBUILD aiohttp-3.6.1.ebuild 2196 BLAKE2B 4bd4b84395061a80b7b5ea6dfd54c50d6255233a4a436c67c085a9f5ee8fb863cc379f7c1e488025c3c76cba370ab14a556294b0bdfcb4df7f7c8378d5661d9e SHA512 b827e5331c62e8e74f51edcffbde4ff6bbb2af08426f705c2518eda1126020bade731325b156b3eb37bc5034b62faaf300a6a1034533d519142744fa864a4e59
MISC metadata.xml 489 BLAKE2B beb80da34848dfe7b81ed65d75923480644ecf42e2c5ce04a7f66f3e729651fdc6035054482aff966ec9f03cfbb812d3be0afd783af69e37f1002182e4885473 SHA512 d8c9e2edb8a57a3b6b02bb5314aef77dc266af6e80fd0300eb0652c59790232017d0062f5b7361b059c382d1c904f0f46cd0e672d1963e9595f3d4dc7514f182
diff --git a/dev-python/aiohttp/aiohttp-3.6.1.ebuild b/dev-python/aiohttp/aiohttp-3.6.1.ebuild
new file mode 100644
index 000000000000..42c6b0667c20
--- /dev/null
+++ b/dev-python/aiohttp/aiohttp-3.6.1.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{5,6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="http client/server for asyncio"
+HOMEPAGE="https://pypi.org/project/aiohttp/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="doc test"
+RESTRICT="!test? ( test )"
+
+CDEPEND="
+ >=dev-python/async_timeout-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/attrs-17.3.0[${PYTHON_USEDEP}]
+ dev-python/chardet[${PYTHON_USEDEP}]
+ >=dev-python/multidict-4.5.0[${PYTHON_USEDEP}]
+ >=dev-python/yarl-1.0[${PYTHON_USEDEP}]
+ dev-python/idna-ssl[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/typing-extensions[${PYTHON_USEDEP}]' \
+ python3_{5,6})
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/cython[${PYTHON_USEDEP}]
+ doc? (
+ >=dev-python/alabaster-0.6.2[${PYTHON_USEDEP}]
+ dev-python/sphinxcontrib-asyncio[${PYTHON_USEDEP}]
+ dev-python/sphinxcontrib-blockdiag[${PYTHON_USEDEP}]
+ dev-python/sphinxcontrib-newsfeed[${PYTHON_USEDEP}]
+ dev-python/sphinxcontrib-spelling[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/sphinx-aiohttp-theme[${PYTHON_USEDEP}]
+ )
+ test? (
+ ${CDEPEND}
+ dev-python/async_generator[${PYTHON_USEDEP}]
+ dev-python/brotlipy[${PYTHON_USEDEP}]
+ >=dev-python/pytest-3.4.0[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ dev-python/trustme[${PYTHON_USEDEP}]
+ www-servers/gunicorn[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND="${CDEPEND}"
+
+DOCS=( CHANGES.rst CONTRIBUTING.rst CONTRIBUTORS.txt HISTORY.rst README.rst )
+
+python_prepare_all() {
+ # FIXME
+ rm tests/test_pytest_plugin.py || die
+ sed -i -e 's:test_testcase_no_app:_&:' tests/test_test_utils.py || die
+
+ # remove pointless dep on pytest-cov
+ sed -i -e '/addopts/s/--cov=aiohttp//' pytest.ini || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ pytest -vv || die "Tests fail with ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+
+ distutils-r1_python_install_all
+}