summaryrefslogtreecommitdiff
path: root/dev-python/aiodns/aiodns-3.1.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/aiodns/aiodns-3.1.1.ebuild')
-rw-r--r--dev-python/aiodns/aiodns-3.1.1.ebuild34
1 files changed, 0 insertions, 34 deletions
diff --git a/dev-python/aiodns/aiodns-3.1.1.ebuild b/dev-python/aiodns/aiodns-3.1.1.ebuild
deleted file mode 100644
index e02ba3f75621..000000000000
--- a/dev-python/aiodns/aiodns-3.1.1.ebuild
+++ /dev/null
@@ -1,34 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..12} )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="Simple DNS resolver for asyncio"
-HOMEPAGE="https://github.com/saghul/aiodns/"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 ~arm64 ~riscv ~x86"
-
-# Tests fail with network-sandbox, since they try to resolve google.com
-PROPERTIES="test_network"
-RESTRICT="test"
-
-RDEPEND=">=dev-python/pycares-3[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}"
-
-distutils_enable_tests pytest
-
-python_test() {
- local EPYTEST_DESELECT=(
- # Internet changed, https://github.com/saghul/aiodns/issues/107
- tests.py::DNSTest::test_query_bad_chars
- )
-
- epytest tests.py
-}