summaryrefslogtreecommitdiff
path: root/dev-python/aiocache/aiocache-0.12.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/aiocache/aiocache-0.12.2.ebuild')
-rw-r--r--dev-python/aiocache/aiocache-0.12.2.ebuild9
1 files changed, 7 insertions, 2 deletions
diff --git a/dev-python/aiocache/aiocache-0.12.2.ebuild b/dev-python/aiocache/aiocache-0.12.2.ebuild
index dd8c5bb60fe4..be1ff1ba4a4d 100644
--- a/dev-python/aiocache/aiocache-0.12.2.ebuild
+++ b/dev-python/aiocache/aiocache-0.12.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -32,6 +32,10 @@ BDEPEND="
distutils_enable_tests pytest
python_test() {
+ local EPYTEST_DESELECT=(
+ # broken by newer dev-python/redis (?), removed upstream
+ tests/ut/backends/test_redis.py::TestRedisBackend::test_close
+ )
local EPYTEST_IGNORE=(
# benchmarks
tests/performance
@@ -39,7 +43,8 @@ python_test() {
tests/ut/backends/test_memcached.py
)
- epytest -o addopts= -m "not memcached"
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -o addopts= -m "not memcached" -p asyncio -p pytest_mock
}
src_test() {