summaryrefslogtreecommitdiff
path: root/dev-python/a2wsgi/a2wsgi-1.10.3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/a2wsgi/a2wsgi-1.10.3.ebuild')
-rw-r--r--dev-python/a2wsgi/a2wsgi-1.10.3.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/a2wsgi/a2wsgi-1.10.3.ebuild b/dev-python/a2wsgi/a2wsgi-1.10.3.ebuild
new file mode 100644
index 000000000000..4dab2405e9f9
--- /dev/null
+++ b/dev-python/a2wsgi/a2wsgi-1.10.3.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=pdm-backend
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Convert WSGI app to ASGI app or ASGI app to WSGI app"
+HOMEPAGE="
+ https://github.com/abersheeran/a2wsgi/
+ https://pypi.org/project/a2wsgi/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+BDEPEND="
+ test? (
+ <dev-python/asgiref-4[${PYTHON_USEDEP}]
+ >=dev-python/asgiref-3.2.7[${PYTHON_USEDEP}]
+ <dev-python/httpx-1[${PYTHON_USEDEP}]
+ >=dev-python/httpx-0.22.0[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest