summaryrefslogtreecommitdiff
path: root/dev-python/WSME/WSME-0.9.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/WSME/WSME-0.9.1.ebuild')
-rw-r--r--dev-python/WSME/WSME-0.9.1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/WSME/WSME-0.9.1.ebuild b/dev-python/WSME/WSME-0.9.1.ebuild
new file mode 100644
index 000000000000..dd2ca03acd66
--- /dev/null
+++ b/dev-python/WSME/WSME-0.9.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_4 python3_5 )
+
+inherit distutils-r1
+
+DESCRIPTION="Simplify the writing of REST APIs, and extend them with additional protocols."
+HOMEPAGE="https://pythonhosted.org/WSME"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ~arm64 x86"
+IUSE=""
+
+CDEPEND=">=dev-python/pbr-1.3[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}
+"
+RDEPEND="
+ ${CDEPEND}
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+ >=dev-python/webob-1.2.3[${PYTHON_USEDEP}]
+ dev-python/simplegeneric[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ >=dev-python/netaddr-0.7.12[${PYTHON_USEDEP}]
+"