summaryrefslogtreecommitdiff
path: root/dev-python/Rx/Rx-3.2.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/Rx/Rx-3.2.0.ebuild')
-rw-r--r--dev-python/Rx/Rx-3.2.0.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/Rx/Rx-3.2.0.ebuild b/dev-python/Rx/Rx-3.2.0.ebuild
new file mode 100644
index 000000000000..d7dc1233b7a3
--- /dev/null
+++ b/dev-python/Rx/Rx-3.2.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1 virtualx
+
+MY_P="RxPY-${PV}"
+DESCRIPTION="Reactive Extensions for Python"
+HOMEPAGE="http://reactivex.io/"
+SRC_URI="
+ https://github.com/ReactiveX/RxPY/archive/v${PV}.tar.gz
+ -> ${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_test() {
+ virtx distutils-r1_src_test
+}