summaryrefslogtreecommitdiff
path: root/dev-python/QtPy/QtPy-2.4.1-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/QtPy/QtPy-2.4.1-r1.ebuild')
-rw-r--r--dev-python/QtPy/QtPy-2.4.1-r1.ebuild8
1 files changed, 6 insertions, 2 deletions
diff --git a/dev-python/QtPy/QtPy-2.4.1-r1.ebuild b/dev-python/QtPy/QtPy-2.4.1-r1.ebuild
index 77a7edfb9514..e1495a0f9932 100644
--- a/dev-python/QtPy/QtPy-2.4.1-r1.ebuild
+++ b/dev-python/QtPy/QtPy-2.4.1-r1.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
DISTUTILS_USE_PEP517=setuptools
PYPI_NO_NORMALIZE=1
-PYTHON_COMPAT=( python3_{10..12} )
+PYTHON_COMPAT=( python3_{10..13} )
inherit distutils-r1 virtualx pypi
@@ -30,6 +30,7 @@ unset _IUSE_QT_MODULES
REQUIRED_USE="
|| ( pyqt5 pyqt6 pyside2 pyside6 )
python_targets_python3_12? ( !pyside2 )
+ python_targets_python3_13? ( !pyside2 )
"
# These flags are currently *not* common to the PySide2/6 and PyQt5/6 ebuilds
@@ -139,7 +140,9 @@ BDEPEND="
dev-python/pyside2[webchannel,webengine,websockets,widgets,x11extras]
dev-python/pyside2[xml,xmlpatterns]
dev-qt/qtsql:5[sqlite]
+ dev-python/pyside2-tools[${PYTHON_USEDEP}]
' python3_{10..11})
+ dev-qt/qtsql:5[sqlite]
)
pyside6? (
dev-python/pyside6[${PYTHON_USEDEP}]
@@ -148,6 +151,7 @@ BDEPEND="
dev-python/pyside6[printsupport,qml,quick,quick3d,scxml(-),sensors(-)]
dev-python/pyside6[serialport,spatialaudio(-),speech(-),sql,svg,testlib,webchannel]
dev-python/pyside6[webengine,websockets,widgets,xml]
+ dev-python/pyside6-tools[${PYTHON_USEDEP}]
dev-qt/qtbase:6[sqlite]
)
)