summaryrefslogtreecommitdiff
path: root/dev-python/PySocks/PySocks-1.6.8.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/PySocks/PySocks-1.6.8.ebuild')
-rw-r--r--dev-python/PySocks/PySocks-1.6.8.ebuild30
1 files changed, 0 insertions, 30 deletions
diff --git a/dev-python/PySocks/PySocks-1.6.8.ebuild b/dev-python/PySocks/PySocks-1.6.8.ebuild
deleted file mode 100644
index 95d6ac757db0..000000000000
--- a/dev-python/PySocks/PySocks-1.6.8.ebuild
+++ /dev/null
@@ -1,30 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy{,3} )
-
-inherit distutils-r1
-
-DESCRIPTION="SOCKS client module"
-HOMEPAGE="https://github.com/Anorov/PySocks https://pypi.org/project/PySocks/"
-SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x64-cygwin ~amd64-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
-IUSE="test"
-
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- dev-python/pytest[${PYTHON_USEDEP}]
- )"
-
-# Required module test-server isn't in the tree yet and once that's added
-# psutil will need keywords added as well since it's used too.
-RESTRICT=test
-
-python_test() {
- py.test -v || die "Tests fail with ${EPYTHON}"
-}