summaryrefslogtreecommitdiff
path: root/dev-python/PyQt6-sip/PyQt6-sip-13.8.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/PyQt6-sip/PyQt6-sip-13.8.0.ebuild')
-rw-r--r--dev-python/PyQt6-sip/PyQt6-sip-13.8.0.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-python/PyQt6-sip/PyQt6-sip-13.8.0.ebuild b/dev-python/PyQt6-sip/PyQt6-sip-13.8.0.ebuild
new file mode 100644
index 000000000000..ddd2a7ebcb51
--- /dev/null
+++ b/dev-python/PyQt6-sip/PyQt6-sip-13.8.0.ebuild
@@ -0,0 +1,21 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYPI_PN=${PN/-/_}
+# keep compat in sync with PyQt6 or else it confuses some revdeps
+PYTHON_COMPAT=( python3_{10..13} )
+inherit distutils-r1 pypi
+
+DESCRIPTION="sip module support for PyQt6"
+# note that PyQt6-sip is currently not on github, but this is the
+# homepage listed upstream as of the writing of this
+HOMEPAGE="https://github.com/Python-SIP/sip/"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv"