summaryrefslogtreecommitdiff
path: root/dev-python/PyQt5/PyQt5-5.10.1-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/PyQt5/PyQt5-5.10.1-r1.ebuild')
-rw-r--r--dev-python/PyQt5/PyQt5-5.10.1-r1.ebuild13
1 files changed, 7 insertions, 6 deletions
diff --git a/dev-python/PyQt5/PyQt5-5.10.1-r1.ebuild b/dev-python/PyQt5/PyQt5-5.10.1-r1.ebuild
index 8b331f240fb1..62e0077bd41d 100644
--- a/dev-python/PyQt5/PyQt5-5.10.1-r1.ebuild
+++ b/dev-python/PyQt5/PyQt5-5.10.1-r1.ebuild
@@ -1,19 +1,20 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} )
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
inherit multibuild python-r1 qmake-utils
DESCRIPTION="Python bindings for the Qt framework"
HOMEPAGE="https://www.riverbankcomputing.com/software/pyqt/intro"
-MY_P=${PN}_gpl-${PV/_pre/.dev}
+MY_PN=PyQt5
+MY_P=${MY_PN}_gpl-${PV/_pre/.dev}
if [[ ${PV} == *_pre* ]]; then
- SRC_URI="https://dev.gentoo.org/~pesa/distfiles/${MY_P}.tar.xz"
+ SRC_URI="https://dev.gentoo.org/~pesa/distfiles/${MY_P}.tar.gz"
else
- SRC_URI="mirror://sourceforge/pyqt/${MY_P}.tar.gz"
+ SRC_URI="https://www.riverbankcomputing.com/static/Downloads/${MY_PN}/${PV}/${MY_P}.tar.gz"
fi
LICENSE="GPL-3"
@@ -158,7 +159,7 @@ src_configure() {
echo "${myconf[@]}"
"${myconf[@]}" || die
- eqmake5 -recursive ${PN}.pro
+ eqmake5 -recursive ${MY_PN}.pro
}
python_foreach_impl run_in_build_dir configuration
}