summaryrefslogtreecommitdiff
path: root/dev-python/PyQt-builder/PyQt-builder-1.12.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/PyQt-builder/PyQt-builder-1.12.2.ebuild')
-rw-r--r--dev-python/PyQt-builder/PyQt-builder-1.12.2.ebuild37
1 files changed, 0 insertions, 37 deletions
diff --git a/dev-python/PyQt-builder/PyQt-builder-1.12.2.ebuild b/dev-python/PyQt-builder/PyQt-builder-1.12.2.ebuild
deleted file mode 100644
index 3c851baf7523..000000000000
--- a/dev-python/PyQt-builder/PyQt-builder-1.12.2.ebuild
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{9..11} )
-inherit distutils-r1
-
-DESCRIPTION="The PEP 517 compliant PyQt build system"
-HOMEPAGE="https://www.riverbankcomputing.com/software/pyqt-builder/ https://pypi.org/project/PyQt-builder/"
-
-MY_P=${PN}-${PV/_pre/.dev}
-if [[ ${PV} == *_pre* ]]; then
- SRC_URI="https://dev.gentoo.org/~pesa/distfiles/${MY_P}.tar.gz"
-else
- SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz"
-fi
-S=${WORKDIR}/${MY_P}
-
-LICENSE="|| ( GPL-2 GPL-3 SIP )"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 ~loong ~ppc ppc64 ~riscv x86"
-
-RDEPEND="
- dev-python/packaging[${PYTHON_USEDEP}]
- >=dev-python/sip-6.3[${PYTHON_USEDEP}]
-"
-
-distutils_enable_sphinx doc --no-autodoc
-
-python_prepare_all() {
- # don't install prebuilt Windows DLLs
- sed -i -e "s:'dlls/\*/\*',::" setup.py || die
- rm -r "${PN/-/_}.egg-info" || die
-
- distutils-r1_python_prepare_all
-}