summaryrefslogtreecommitdiff
path: root/dev-python/PyQt-builder/PyQt-builder-1.10.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/PyQt-builder/PyQt-builder-1.10.1.ebuild')
-rw-r--r--dev-python/PyQt-builder/PyQt-builder-1.10.1.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/PyQt-builder/PyQt-builder-1.10.1.ebuild b/dev-python/PyQt-builder/PyQt-builder-1.10.1.ebuild
new file mode 100644
index 000000000000..c7f4ec9ff355
--- /dev/null
+++ b/dev-python/PyQt-builder/PyQt-builder-1.10.1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{7..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="The PEP 517 compliant PyQt build system"
+HOMEPAGE="https://www.riverbankcomputing.com/software/pyqt-builder/ https://pypi.org/project/PyQt-builder/ https://www.riverbankcomputing.com/static/Docs/PyQt-builder/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="|| ( GPL-2 GPL-3 SIP )"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+SLOT="0"
+RDEPEND="dev-python/sip[${PYTHON_USEDEP}]"
+BDEPEND="${RDEPEND}"
+
+src_install() {
+ distutils-r1_src_install
+}