summaryrefslogtreecommitdiff
path: root/dev-python/OutputCheck
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/OutputCheck')
-rw-r--r--dev-python/OutputCheck/Manifest2
-rw-r--r--dev-python/OutputCheck/OutputCheck-0.4.2-r2.ebuild (renamed from dev-python/OutputCheck/OutputCheck-0.4.2-r1.ebuild)17
2 files changed, 9 insertions, 10 deletions
diff --git a/dev-python/OutputCheck/Manifest b/dev-python/OutputCheck/Manifest
index 72631b4416a0..be885c6fa87f 100644
--- a/dev-python/OutputCheck/Manifest
+++ b/dev-python/OutputCheck/Manifest
@@ -1,4 +1,4 @@
AUX OutputCheck-0.4.2-Driver.patch 738 BLAKE2B 972452f782966bc0237c4bb134ecb31c4d6126e08fda3630899f51e7028120d8cc0a9a89a33018648369a84e64e335b6520bf4e220c0fcde5257ad90640deb12 SHA512 1d0a3b694261a3ffa3fc51add70c3f6a0888120da1ef5aa4b09c57777b4b9497cdb44c03e294018c3f4c70d35aed7050638bc77101aa3e99fd0367ee03358118
DIST OutputCheck-0.4.2.gh.tar.gz 16436 BLAKE2B 8c1678746b9fc11cf7b554da83a2e5a51c7095931894a543340e905ccff1e7240f1bb8ec12d348af9662ce7e515d70d6e8a93d1e6ab15629545aa5019a7fe648 SHA512 0abd1ca69c4ef683cc455c222979b313ed8b4906725cc534b80906cc4fb9a0acad855d4a6c39aa4777bbdc35309857082197a0cacdc191e4afb8a8a9a4bb2bed
-EBUILD OutputCheck-0.4.2-r1.ebuild 958 BLAKE2B 532336649a51284cf40546763dfa18b317a0661de377f9d9addb468d03d81826b5e15bf1d6d883baa60ca21b2e13a7c6c59d2a762cd768e178344b343395069b SHA512 a96da93e60cd7c79d9e49aeca13206efda732ef59caa6665beb8e7d493e49611c527e903860e219e805fb8a97eae63a611189066a74fb779c11c2d1622312e84
+EBUILD OutputCheck-0.4.2-r2.ebuild 964 BLAKE2B d8f09be4f888ea30c9ba2eb158d376faa1cc2e4bb2b95696423a3e631c4b9147e58c5896ac49c146deb72d34ea4306bb4c224608adfc47b37f46ff5d09552d84 SHA512 532b8a21c5010e41fa28eabb2f0bf0ccade12493a967b0c92dbc26ad654d447f26e7895ccb92522322c154862a98da1ad6bd291d2539dd8d67a3a3fa888f742f
MISC metadata.xml 899 BLAKE2B fb3372208ef75e4cda72be765d15426707f4879f5ac55ac79adc6991dfc61d624e33b30f549d83877f02cb6aa9a3f1b64a9aff6eb922e8de5221036808ae14d2 SHA512 265f6dfca1e7b83a72a6b9edb4399e49bd91eb7273bcd3b2d92f32d647963bb05ae2408b011a397d26772b5016c6b40809afb56090c36b449c263a5fa5b3dd05
diff --git a/dev-python/OutputCheck/OutputCheck-0.4.2-r1.ebuild b/dev-python/OutputCheck/OutputCheck-0.4.2-r2.ebuild
index 814333b341ff..01ac4eea4db6 100644
--- a/dev-python/OutputCheck/OutputCheck-0.4.2-r1.ebuild
+++ b/dev-python/OutputCheck/OutputCheck-0.4.2-r2.ebuild
@@ -1,16 +1,17 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_COMPAT=( python3_{9..12} )
inherit distutils-r1
DESCRIPTION="A tool for checking the output of console programs inspired by LLVM's FileCheck"
HOMEPAGE="https://github.com/stp/OutputCheck/"
-SRC_URI="https://github.com/stp/${PN}/archive/${PV}.tar.gz -> ${P}.gh.tar.gz"
+SRC_URI="https://github.com/stp/${PN}/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
LICENSE="BSD"
SLOT="0"
@@ -20,20 +21,18 @@ RESTRICT="!test? ( test )"
BDEPEND="test? ( dev-python/lit[${PYTHON_USEDEP}] )"
-PATCHES=( "${FILESDIR}"/${P}-Driver.patch )
+PATCHES=( "${FILESDIR}/${PN}-0.4.2-Driver.patch" )
src_prepare() {
distutils-r1_src_prepare
# Remove bad tests.
- rm "${S}"/tests/invalid-regex-syntax.smt2 ||
- die "failed to remove bad tests"
+ rm "${S}/tests/invalid-regex-syntax.smt2" || die "failed to remove bad tests"
# Create RELEASE-VERSION file.
- echo ${PV} > "${S}"/RELEASE-VERSION ||
- die "failed to write RELEASE-VERSION"
+ echo "${PV}" > "${S}/RELEASE-VERSION" || die "failed to write RELEASE-VERSION"
}
python_test() {
- lit --verbose "${S}"/tests || die "running test with ${EPYTHON} failed"
+ lit --verbose "${S}/tests" || die "running test with ${EPYTHON} failed"
}