summaryrefslogtreecommitdiff
path: root/dev-python/Nuitka
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/Nuitka')
-rw-r--r--dev-python/Nuitka/Manifest7
-rw-r--r--dev-python/Nuitka/Nuitka-1.2.6.ebuild55
-rw-r--r--dev-python/Nuitka/Nuitka-1.2.7.ebuild54
-rw-r--r--dev-python/Nuitka/Nuitka-1.3.1.ebuild54
-rw-r--r--dev-python/Nuitka/metadata.xml26
5 files changed, 196 insertions, 0 deletions
diff --git a/dev-python/Nuitka/Manifest b/dev-python/Nuitka/Manifest
new file mode 100644
index 000000000000..8b3df4637a2d
--- /dev/null
+++ b/dev-python/Nuitka/Manifest
@@ -0,0 +1,7 @@
+DIST Nuitka-1.2.6.tar.gz 3959091 BLAKE2B b326409f49d722bcac7df3e2c5caae7fb9ccf2b2991d2cf003a4db7bd268af95b7423da3b69b93b45c2aa1e3461faac90872b01f2d2277c5e9f7c71bedb0df56 SHA512 b12f694f8ac26213fd1242c66c2a37be1940bafef8a4949f0e401f056a1f72a010d1df237a828317ed0c88530206c31e617f03e4bccf6c934b967f8ddaef330f
+DIST Nuitka-1.2.7.tar.gz 3960368 BLAKE2B 582ad7f7a96577fd87a4f9fe083d90f532f2ddd7824b4105d258551b559d9390fba428b80223c6ca4d00eda451cc21a63449c7370a3e43d4b7f9a28fc6bba4c9 SHA512 37a3c29614102dc80f916ac483a6e87322b7a3b9cf25355bdf2f29d84e33300640607fcb7fdc6a338431bc890b4337512c43368e47a2d69c7254b7b7794bb35b
+DIST Nuitka-1.3.1.tar.gz 4028497 BLAKE2B 877413970a1e169abe8b9770d927d2e9a33bcd775466adc7287fdcc8f69d412fae249ea96a16aca4166d655f1a016852e06018f55c0b62afe4b53c5b1c540870 SHA512 09f8ff13f14af20ee2fa8b80714ff52a3bc2a36658113e122ba383f34e9ca8c27af42b14cb06477e3a2ed2e5dfa60e10295c4f96a209db699719c456518c464d
+EBUILD Nuitka-1.2.6.ebuild 1215 BLAKE2B efeaa1c3d00d7271353da9adc21c65bacb0a8e30dfefd73871c3ba7f37133baeb6dd4cc413d0303fde7396bba94802a729db21afa6a285ac240e7f45fe92c6da SHA512 5588605c444f1c9f6ca82289c60b7a5d843074180465f8f57e0282b384b2be913451c89dc519623dfe9ffa9b5a128188a18b60bcd80d9a49d27d007a2f0c5a0d
+EBUILD Nuitka-1.2.7.ebuild 1195 BLAKE2B 4fd1a26dec76bee05b6dc9bb526572441095e01107cb45f7b791aebc653d286cce0cf19f1b3dba2e5d626897bf2f7e0284f85f4b05602676234cbc427081ab39 SHA512 9cafcdbdbb6876b29b8ae2b1822392780fadd74b1a01df6762f397a2e16a01829629ca4961abea174b2085c05cce8ba498e6836b77c4f9ecb1fb0e2c2fe0674e
+EBUILD Nuitka-1.3.1.ebuild 1191 BLAKE2B d09596501d4167392016199b9c9246ab0f57ceca5667340672d9cdca0d7ebe5288eef83e9485bffe607a8f8af1cea705809ab94ca730e1abe39929109b44f504 SHA512 edfd1f3c1abb7d0be5a943e92a4b0ac79f205d5df93a453c8922aad73d3df4489a0b1a4bb4ed11a1e77b493633231f156b6be6faa17629a6d5b1ba44295f05c5
+MISC metadata.xml 943 BLAKE2B d7ab883773e7480dcfb4b79932a3874e2274669169a24a54aa622a2a0ac079e0296da4bd196d166cb11fcff785985da0b10d0fae351032914ccf312c9bb9833c SHA512 625d8760b8e849c6e014856f584cb42f50bb5ebb1fa648cb704a5a1baf175e7d2ce9f43f6f724d11c81a68e364b6ac1c38459540b58f2ccd6a675902af5b1cc9
diff --git a/dev-python/Nuitka/Nuitka-1.2.6.ebuild b/dev-python/Nuitka/Nuitka-1.2.6.ebuild
new file mode 100644
index 000000000000..5072e727e4eb
--- /dev/null
+++ b/dev-python/Nuitka/Nuitka-1.2.6.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1 flag-o-matic optfeature
+
+DESCRIPTION="Python to native compiler"
+HOMEPAGE="
+ https://www.nuitka.net/
+ https://github.com/Nuitka/Nuitka/
+ https://pypi.org/project/Nuitka/
+"
+SRC_URI="https://nuitka.net/releases/${P^}.tar.gz"
+S=${WORKDIR}/${P^}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~loong ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-util/scons[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ ${RDEPEND}
+ test? ( dev-util/ccache )
+"
+
+DOCS=( Changelog.pdf Developer_Manual.pdf README.pdf )
+
+distutils-r1_src_prepare() {
+ # remove vendored version of SCons that is Python2 only
+ # this should be removed when upstream removes support for Python2
+ rm -vR "nuitka/build/inline_copy/lib/scons-2.3.2/SCons" || die
+ eapply_user
+}
+
+python_install() {
+ distutils-r1_python_install
+ doman doc/nuitka3.1 doc/nuitka3-run.1
+}
+
+python_test() {
+ append-ldflags -Wl,--no-warn-search-mismatch
+ ./tests/basics/run_all.py search || die
+}
+
+pkg_postinst() {
+ optfeature "support for stand-alone executables" app-admin/chrpath
+}
diff --git a/dev-python/Nuitka/Nuitka-1.2.7.ebuild b/dev-python/Nuitka/Nuitka-1.2.7.ebuild
new file mode 100644
index 000000000000..c815260c5eb9
--- /dev/null
+++ b/dev-python/Nuitka/Nuitka-1.2.7.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1 flag-o-matic optfeature
+
+DESCRIPTION="Python to native compiler"
+HOMEPAGE="
+ https://www.nuitka.net/
+ https://github.com/Nuitka/Nuitka/
+ https://pypi.org/project/Nuitka/
+"
+SRC_URI="https://nuitka.net/releases/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~loong ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-util/scons[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ ${RDEPEND}
+ test? ( dev-util/ccache )
+"
+
+DOCS=( Changelog.pdf Developer_Manual.pdf README.pdf )
+
+distutils-r1_src_prepare() {
+ # remove vendored version of SCons that is Python2 only
+ # this should be removed when upstream removes support for Python2
+ rm -vR "nuitka/build/inline_copy/lib/scons-2.3.2/SCons" || die
+ eapply_user
+}
+
+python_install() {
+ distutils-r1_python_install
+ doman doc/nuitka3.1 doc/nuitka3-run.1
+}
+
+python_test() {
+ append-ldflags -Wl,--no-warn-search-mismatch
+ ./tests/basics/run_all.py search || die
+}
+
+pkg_postinst() {
+ optfeature "support for stand-alone executables" app-admin/chrpath
+}
diff --git a/dev-python/Nuitka/Nuitka-1.3.1.ebuild b/dev-python/Nuitka/Nuitka-1.3.1.ebuild
new file mode 100644
index 000000000000..6ba48aa72091
--- /dev/null
+++ b/dev-python/Nuitka/Nuitka-1.3.1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_10 )
+
+inherit distutils-r1 flag-o-matic optfeature
+
+DESCRIPTION="Python to native compiler"
+HOMEPAGE="
+ https://www.nuitka.net/
+ https://github.com/Nuitka/Nuitka/
+ https://pypi.org/project/Nuitka/
+"
+SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~loong ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-util/scons[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ ${RDEPEND}
+ test? ( dev-util/ccache )
+"
+
+DOCS=( Changelog.pdf Developer_Manual.pdf README.pdf )
+
+distutils-r1_src_prepare() {
+ # remove vendored version of SCons that is Python2 only
+ # this should be removed when upstream removes support for Python2
+ rm -vR "nuitka/build/inline_copy/lib/scons-2.3.2/SCons" || die
+ eapply_user
+}
+
+python_install() {
+ distutils-r1_python_install
+ doman doc/nuitka3.1 doc/nuitka3-run.1
+}
+
+python_test() {
+ append-ldflags -Wl,--no-warn-search-mismatch
+ ./tests/basics/run_all.py search || die
+}
+
+pkg_postinst() {
+ optfeature "support for stand-alone executables" app-admin/chrpath
+}
diff --git a/dev-python/Nuitka/metadata.xml b/dev-python/Nuitka/metadata.xml
new file mode 100644
index 000000000000..465fe958dc3b
--- /dev/null
+++ b/dev-python/Nuitka/metadata.xml
@@ -0,0 +1,26 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <name>Oz Tiram</name>
+ <email>oz.tiram@gmail.com</email>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <longdescription lang="en">
+ Python compiler with full language support and CPython compatibility
+ This Python compiler achieves full language compatibility and compiles Python
+ code into compiled objects that are not second class at all. Instead they can
+ be used in the same way as pure Python objects.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">Nuitka/Nuitka</remote-id>
+ <remote-id type="pypi">Nuitka</remote-id>
+ </upstream>
+</pkgmetadata>