summaryrefslogtreecommitdiff
path: root/dev-python/GitPython/GitPython-3.1.43.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/GitPython/GitPython-3.1.43.ebuild')
-rw-r--r--dev-python/GitPython/GitPython-3.1.43.ebuild5
1 files changed, 4 insertions, 1 deletions
diff --git a/dev-python/GitPython/GitPython-3.1.43.ebuild b/dev-python/GitPython/GitPython-3.1.43.ebuild
index 29051eb6c6da..ab17a602e224 100644
--- a/dev-python/GitPython/GitPython-3.1.43.ebuild
+++ b/dev-python/GitPython/GitPython-3.1.43.ebuild
@@ -5,7 +5,7 @@ EAPI=8
DISTUTILS_USE_PEP517=setuptools
PYPI_NO_NORMALIZE=1
-PYTHON_COMPAT=( python3_{10..12} )
+PYTHON_COMPAT=( python3_{10..13} )
PYTHON_REQ_USE="threads(+)"
inherit distutils-r1 pypi
@@ -39,6 +39,9 @@ BDEPEND="
test? (
>=dev-python/ddt-1.1.1[${PYTHON_USEDEP}]
dev-python/pytest-mock[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+ ' 3.10)
)
"