summaryrefslogtreecommitdiff
path: root/dev-python/Faker/Faker-22.7.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/Faker/Faker-22.7.0.ebuild')
-rw-r--r--dev-python/Faker/Faker-22.7.0.ebuild40
1 files changed, 0 insertions, 40 deletions
diff --git a/dev-python/Faker/Faker-22.7.0.ebuild b/dev-python/Faker/Faker-22.7.0.ebuild
deleted file mode 100644
index 95ff3728fb55..000000000000
--- a/dev-python/Faker/Faker-22.7.0.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 2022-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYPI_NO_NORMALIZE=1
-PYTHON_COMPAT=( pypy3 python3_{10..12} )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="A Python package that generates fake data for you"
-HOMEPAGE="
- https://github.com/joke2k/faker/
- https://pypi.org/project/Faker/
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 ~loong ppc ppc64 ~riscv ~s390 sparc x86"
-
-RDEPEND="
- >=dev-python/python-dateutil-2.4.2[${PYTHON_USEDEP}]
- !dev-ruby/faker
-"
-BDEPEND="
- test? (
- dev-python/freezegun[${PYTHON_USEDEP}]
- dev-python/pillow[${PYTHON_USEDEP},tiff]
- dev-python/validators[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-python_test() {
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- local -x PYTEST_PLUGINS=faker.contrib.pytest.plugin
- epytest
-}