summaryrefslogtreecommitdiff
path: root/dev-python/Babel
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/Babel')
-rw-r--r--dev-python/Babel/Babel-2.12.1.ebuild74
-rw-r--r--dev-python/Babel/Babel-2.13.0.ebuild69
-rw-r--r--dev-python/Babel/Babel-2.13.1.ebuild2
-rw-r--r--dev-python/Babel/Manifest7
-rw-r--r--dev-python/Babel/files/Babel-2.12.1-dst-test.patch46
5 files changed, 2 insertions, 196 deletions
diff --git a/dev-python/Babel/Babel-2.12.1.ebuild b/dev-python/Babel/Babel-2.12.1.ebuild
deleted file mode 100644
index 2fd48478ab15..000000000000
--- a/dev-python/Babel/Babel-2.12.1.ebuild
+++ /dev/null
@@ -1,74 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYPI_NO_NORMALIZE=1
-PYTHON_COMPAT=( pypy3 python3_{10..12} )
-PYTHON_REQ_USE="threads(+)"
-
-inherit distutils-r1 pypi
-
-# see scripts/download_import_cldr.py
-CLDR_PV=42.0
-DESCRIPTION="Collection of tools for internationalizing Python applications"
-HOMEPAGE="
- https://babel.pocoo.org/
- https://pypi.org/project/Babel/
- https://github.com/python-babel/babel/
-"
-SRC_URI+="
- https://unicode.org/Public/cldr/${CLDR_PV%.*}/cldr-common-${CLDR_PV}.zip
-"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~x64-macos"
-
-# RDEPEND in BDEPEND for import_cldr.py usage, bug #852158
-BDEPEND="
- app-arch/unzip
- ${RDEPEND}
- test? (
- dev-python/freezegun[${PYTHON_USEDEP}]
- dev-python/pytz[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_sphinx docs
-distutils_enable_tests pytest
-
-src_prepare() {
- local PATCHES=(
- "${FILESDIR}/${P}-dst-test.patch"
- )
-
- rm babel/locale-data/*.dat || die
- rm babel/global.dat || die
- distutils-r1_src_prepare
-}
-
-python_configure() {
- if [[ ! -f babel/global.dat ]]; then
- "${EPYTHON}" scripts/import_cldr.py "${WORKDIR}"/common || die
- fi
-}
-
-python_test() {
- local EPYTEST_DESELECT=()
- if [[ ${EPYTHON} == python3.12 ]]; then
- EPYTEST_DESELECT+=(
- # seems to be a corner case, might be a regression in cpython
- # https://github.com/python-babel/babel/issues/1005
- tests/messages/test_extract.py::ExtractPythonTestCase::test_utf8_message_with_utf8_bom
- tests/messages/test_extract.py::ExtractPythonTestCase::test_utf8_message_with_utf8_bom_and_magic_comment
- tests/messages/test_extract.py::ExtractPythonTestCase::test_utf8_raw_strings_match_unicode_strings
- tests/messages/test_extract.py::ExtractTestCase::test_f_strings
- tests/messages/test_extract.py::ExtractTestCase::test_f_strings_non_utf8
- )
- fi
-
- local -x TZ=UTC
- epytest
-}
diff --git a/dev-python/Babel/Babel-2.13.0.ebuild b/dev-python/Babel/Babel-2.13.0.ebuild
deleted file mode 100644
index b2e3db74dd6d..000000000000
--- a/dev-python/Babel/Babel-2.13.0.ebuild
+++ /dev/null
@@ -1,69 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYPI_NO_NORMALIZE=1
-PYTHON_COMPAT=( pypy3 python3_{10..12} )
-PYTHON_REQ_USE="threads(+)"
-
-inherit distutils-r1 pypi
-
-# see scripts/download_import_cldr.py
-CLDR_PV=42.0
-DESCRIPTION="Collection of tools for internationalizing Python applications"
-HOMEPAGE="
- https://babel.pocoo.org/
- https://pypi.org/project/Babel/
- https://github.com/python-babel/babel/
-"
-SRC_URI+="
- https://unicode.org/Public/cldr/${CLDR_PV%.*}/cldr-common-${CLDR_PV}.zip
-"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
-
-# RDEPEND in BDEPEND for import_cldr.py usage, bug #852158
-BDEPEND="
- app-arch/unzip
- ${RDEPEND}
- test? (
- dev-python/freezegun[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_sphinx docs
-distutils_enable_tests pytest
-
-src_prepare() {
- rm babel/locale-data/*.dat || die
- rm babel/global.dat || die
- distutils-r1_src_prepare
-}
-
-python_configure() {
- if [[ ! -f babel/global.dat ]]; then
- "${EPYTHON}" scripts/import_cldr.py "${WORKDIR}"/common || die
- fi
-}
-
-python_test() {
- local EPYTEST_DESELECT=()
- if [[ ${EPYTHON} == python3.12 ]]; then
- EPYTEST_DESELECT+=(
- # seems to be a corner case, might be a regression in cpython
- # https://github.com/python-babel/babel/issues/1005
- tests/messages/test_extract.py::ExtractPythonTestCase::test_utf8_message_with_utf8_bom
- tests/messages/test_extract.py::ExtractPythonTestCase::test_utf8_message_with_utf8_bom_and_magic_comment
- tests/messages/test_extract.py::ExtractPythonTestCase::test_utf8_raw_strings_match_unicode_strings
- tests/messages/test_extract.py::ExtractTestCase::test_f_strings
- tests/messages/test_extract.py::ExtractTestCase::test_f_strings_non_utf8
- )
- fi
-
- local -x TZ=UTC
- epytest
-}
diff --git a/dev-python/Babel/Babel-2.13.1.ebuild b/dev-python/Babel/Babel-2.13.1.ebuild
index b2e3db74dd6d..7c3b6a84f66d 100644
--- a/dev-python/Babel/Babel-2.13.1.ebuild
+++ b/dev-python/Babel/Babel-2.13.1.ebuild
@@ -24,7 +24,7 @@ SRC_URI+="
LICENSE="BSD"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~x64-macos"
# RDEPEND in BDEPEND for import_cldr.py usage, bug #852158
BDEPEND="
diff --git a/dev-python/Babel/Manifest b/dev-python/Babel/Manifest
index dc86e684dd4c..38d3a21add03 100644
--- a/dev-python/Babel/Manifest
+++ b/dev-python/Babel/Manifest
@@ -1,9 +1,4 @@
-AUX Babel-2.12.1-dst-test.patch 1853 BLAKE2B 6438546ad48083839b8c3da4ff1a3af1dca97aa8fa80f5bcb97fe5e582d74d0766c3d2eb7b239fc558d872d3ce1aac64db7adee88ce5989452ff55962399bb35 SHA512 83018914dcb8a36cbc27bf4f698d72541627c17a5a162094e8aeaac970ac588b161938bed7c12a15f926b59b63cd1ea6985da82bb8827ac18c6a47d16f2f67a2
-DIST Babel-2.12.1.tar.gz 9906735 BLAKE2B d78838f9a2032eae998f1d751ad803fec81c03be498db934e34e0702d28e0815a7848e55af73ea4dff45e3cf063b9e45ab06c749b8d3f15b7742e209bf3d06ef SHA512 93c4bf343d99a1f47f43f8b828eb79098cb429bac1034d58b5aa49adff68116e458067f3784d997f34515828a7432fd18f7abbaeee59b47a4ee8ea744908b33b
-DIST Babel-2.13.0.tar.gz 9909829 BLAKE2B d30aa56a1aba0c3caaa8fdc9210ca3a21fd70b6687c86de23f63cc2af7e1c4d3d1f00a8fc5287480808b643c21dc997992fddfb9d038248d762137453f0bdb72 SHA512 43f4b5fdd8653639111a767c4b082333d89695507e92c3fca88262f23ee7531d4600ec794e908e78a64da1ec54020c7127df3deaf979e15c4e1067cdb839aa47
DIST Babel-2.13.1.tar.gz 9909844 BLAKE2B f4e0cb6d19c2ecd24a8e67e7d77531248cb5a8d100a5da2a9fe147aef3c15339728c82d4fe9095563c0a0b83dede7c5e27f29281bc3bf0cac5deff7cce409335 SHA512 c27c76456094927bd43ae46cd3e08fcc729dd810a6092da6c86e863523c10746bb3759e7fc9f5396504ab914743ef013904b63b3aa63338602f23aaf83d42cba
DIST cldr-common-42.0.zip 30178050 BLAKE2B 076e3eca12534feff8e0e54bdc1fa38fc0db0f78cac8b4e35b343763a8ac6787745aa36be165684f4d6dda423409c4431a8e4941c53ae7d340ead0b35edbca30 SHA512 315448fe6a9ac2d5a6a7fd1a27b38c5db30fed053654a803d50e3a8d06aa08ad153e8e57089fa094c561f41a54f37eecda0701b47a1813879902be71945aa38a
-EBUILD Babel-2.12.1.ebuild 1973 BLAKE2B 717f6df5508ac58e1dacda596845ba14f7249c7dd2dd6d17191498606fa12c2b33a6f21bee88f34164d8288e5ca4bdc8db6e26013abfb25084406e3d47a11be6 SHA512 852474debeabc9377766eaad7bb590d07d31c8183ab7c8e977a49edfd257ad4357b669f3a3af9539829185756132dcabc32caca060ae476a5c0b336cdcf16100
-EBUILD Babel-2.13.0.ebuild 1888 BLAKE2B 0d6cd5e4dc89230aa6db8192661963a3e8ebf650cf2ca6820de904ec91e7cf30597b26bcc991dad725073e92cf2050d0692c56d931517c83887c9cedefb2b4e8 SHA512 b4641c45490aaf1e6f5a8b3387d132a07772263d2cf3b63f524b03fa5c0e09980a8482eb1118c7f694b4a180f1019132196cd00f563c9ab4675ec9217311910f
-EBUILD Babel-2.13.1.ebuild 1888 BLAKE2B 0d6cd5e4dc89230aa6db8192661963a3e8ebf650cf2ca6820de904ec91e7cf30597b26bcc991dad725073e92cf2050d0692c56d931517c83887c9cedefb2b4e8 SHA512 b4641c45490aaf1e6f5a8b3387d132a07772263d2cf3b63f524b03fa5c0e09980a8482eb1118c7f694b4a180f1019132196cd00f563c9ab4675ec9217311910f
+EBUILD Babel-2.13.1.ebuild 1880 BLAKE2B 36590f75e7a93525e44dc9013b6dcda5867be92accc51fddee6aa0cfbe8e5b6c4869a8cad210f6604b49b6aecbec1c4ccaf3c7e3122d61a447d522caba35a0b3 SHA512 ab75ff506205c2b800ec8e44f2f1537dc8d874954e07c77a92a72694a10cce26fa4ddeb1c9deb2adb5a1e9639473311a1e9c472cbc31e6278561d92a59ab1f1f
MISC metadata.xml 840 BLAKE2B b0f46186ca0a319d3e4e1a658007b2cc59fe3a3ea9ede567af5084593f907e88dbe714d2b70c6a882ec95a5f90d4c0e3620ea0a939ad6e52650e770de88a45ba SHA512 621b66293259fd20c94a62ecf64673f7afcd714c18f054c8c0afe2d14e6e98c8abbdf6b4c5cc0043b5d30e513acab292d85c5587a02a9ae99ca007a28720c921
diff --git a/dev-python/Babel/files/Babel-2.12.1-dst-test.patch b/dev-python/Babel/files/Babel-2.12.1-dst-test.patch
deleted file mode 100644
index 2a732854e7b1..000000000000
--- a/dev-python/Babel/files/Babel-2.12.1-dst-test.patch
+++ /dev/null
@@ -1,46 +0,0 @@
-From 641f58c9951d9f5746cd63743dd337f1340d7bff Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <mgorny@gentoo.org>
-Date: Fri, 7 Apr 2023 14:51:10 +0000
-Subject: [PATCH] Freeze format_time() tests to a specific date to fix test
- failures
-
-Freeze the date when performing the tests for format_time() with
-a timezone specified. Since the time object does not specify a date,
-the formatter uses the format string specific to the current date.
-As a result, if the current DST state is different than when the test
-was last updated, it failed.
-
-This fix covers only regular tests. I have no idea how to do the same
-for doctests.
-
-Issue #988
----
- tests/test_dates.py | 11 ++++++-----
- 1 file changed, 6 insertions(+), 5 deletions(-)
-
-diff --git a/tests/test_dates.py b/tests/test_dates.py
-index b94c710..3f1fc3f 100644
---- a/tests/test_dates.py
-+++ b/tests/test_dates.py
-@@ -601,12 +601,13 @@ def test_format_time(timezone_getter):
- custom = dates.format_time(t, "hh 'o''clock' a, zzzz", tzinfo=eastern, locale='en')
- assert custom == "09 o'clock AM, Eastern Daylight Time"
-
-- t = time(15, 30)
-- paris = dates.format_time(t, format='full', tzinfo=paris, locale='fr_FR')
-- assert paris == '15:30:00 heure normale d’Europe centrale'
-+ with freezegun.freeze_time("2023-01-01"):
-+ t = time(15, 30)
-+ paris = dates.format_time(t, format='full', tzinfo=paris, locale='fr_FR')
-+ assert paris == '15:30:00 heure normale d’Europe centrale'
-
-- us_east = dates.format_time(t, format='full', tzinfo=eastern, locale='en_US')
-- assert us_east == '3:30:00\u202fPM Eastern Standard Time'
-+ us_east = dates.format_time(t, format='full', tzinfo=eastern, locale='en_US')
-+ assert us_east == '3:30:00\u202fPM Eastern Standard Time'
-
-
- def test_format_skeleton(timezone_getter):
---
-2.40.0
-