summaryrefslogtreecommitdiff
path: root/dev-php/pecl-eio/pecl-eio-3.0.0_rc2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-php/pecl-eio/pecl-eio-3.0.0_rc2.ebuild')
-rw-r--r--dev-php/pecl-eio/pecl-eio-3.0.0_rc2.ebuild11
1 files changed, 5 insertions, 6 deletions
diff --git a/dev-php/pecl-eio/pecl-eio-3.0.0_rc2.ebuild b/dev-php/pecl-eio/pecl-eio-3.0.0_rc2.ebuild
index 170f4580cb4b..b7ea9d1d2ba3 100644
--- a/dev-php/pecl-eio/pecl-eio-3.0.0_rc2.ebuild
+++ b/dev-php/pecl-eio/pecl-eio-3.0.0_rc2.ebuild
@@ -2,6 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+
MY_PN="${PN/pecl-}"
MY_PV="${PV/_rc/RC}"
MY_P="${MY_PN}-${MY_PV}"
@@ -15,16 +16,14 @@ DOCS=( README.md )
USE_PHP="php8-0"
inherit php-ext-pecl-r3
-KEYWORDS="~amd64 ~x86"
-LICENSE="PHP-3.01"
-
DESCRIPTION="PHP wrapper for libeio library"
-LICENSE="PHP-3"
+S="${PHP_EXT_S}"
+
+LICENSE="PHP-3.01"
SLOT="0"
+KEYWORDS="~amd64 ~x86"
IUSE="debug"
-S="${PHP_EXT_S}"
-
src_configure() {
local PHP_EXT_ECONF_ARGS=("--with-eio" "$(use_enable debug eio-debug)" )
php-ext-source-r3_src_configure