summaryrefslogtreecommitdiff
path: root/dev-php/pecl-apcu/pecl-apcu-5.1.12.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-php/pecl-apcu/pecl-apcu-5.1.12.ebuild')
-rw-r--r--dev-php/pecl-apcu/pecl-apcu-5.1.12.ebuild10
1 files changed, 5 insertions, 5 deletions
diff --git a/dev-php/pecl-apcu/pecl-apcu-5.1.12.ebuild b/dev-php/pecl-apcu/pecl-apcu-5.1.12.ebuild
index 675490a1e856..da6a7f85c523 100644
--- a/dev-php/pecl-apcu/pecl-apcu-5.1.12.ebuild
+++ b/dev-php/pecl-apcu/pecl-apcu-5.1.12.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -31,10 +31,10 @@ LOCKS="pthreadmutex pthreadrw spinlock semaphore"
LUSE=""
for l in ${LOCKS}; do
- LUSE+="lock_${l} "
+ LUSE+="lock-${l} "
done
-IUSE+=" ${LUSE/lock_pthreadrw/+lock_pthreadrw}"
+IUSE+=" ${LUSE/lock-pthreadrw/+lock-pthreadrw}"
REQUIRED_USE="^^ ( $LUSE )"
@@ -51,8 +51,8 @@ src_configure() {
local PHP_EXT_ECONF_ARGS=(
--enable-apcu
$(use_enable mmap apcu-mmap)
- $(use_enable lock_pthreadrw apcu-rwlocks)
- $(use_enable lock_spinlock apcu-spinlocks)
+ $(use_enable lock-pthreadrw apcu-rwlocks)
+ $(use_enable lock-spinlock apcu-spinlocks)
)
php-ext-source-r3_src_configure