summaryrefslogtreecommitdiff
path: root/dev-php/pecl-amqp/pecl-amqp-1.11.0_rc1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-php/pecl-amqp/pecl-amqp-1.11.0_rc1.ebuild')
-rw-r--r--dev-php/pecl-amqp/pecl-amqp-1.11.0_rc1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-php/pecl-amqp/pecl-amqp-1.11.0_rc1.ebuild b/dev-php/pecl-amqp/pecl-amqp-1.11.0_rc1.ebuild
new file mode 100644
index 000000000000..a25f1b277b3e
--- /dev/null
+++ b/dev-php/pecl-amqp/pecl-amqp-1.11.0_rc1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+USE_PHP="php7-3 php7-4 php8-0 php8-1"
+MY_P="${PN/pecl-/}-${PV/_rc/RC}"
+PHP_EXT_S="${WORKDIR}/${MY_P}"
+PHP_EXT_PECL_FILENAME="${MY_P}.tgz"
+
+inherit php-ext-pecl-r3
+
+KEYWORDS="~amd64 ~x86"
+
+DESCRIPTION="PHP Bindings for AMQP 0-9-1 compatible brokers"
+LICENSE="PHP-3.01"
+SLOT="0"
+IUSE=""
+
+S="${PHP_EXT_S}"
+
+# Tests require running rabbitmq-server on localhost which requires epmd
+# which only accepts /var/run/epmd.pid as pidfile.
+RESTRICT="test"
+
+BDEPEND="virtual/pkgconfig"
+RDEPEND=">=net-libs/rabbitmq-c-0.5.2:=[ssl]"
+DEPEND="${RDEPEND}"
+PHP_EXT_ECONF_ARGS=()