summaryrefslogtreecommitdiff
path: root/dev-php/cphplib/cphplib-0.51-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-php/cphplib/cphplib-0.51-r2.ebuild')
-rw-r--r--dev-php/cphplib/cphplib-0.51-r2.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-php/cphplib/cphplib-0.51-r2.ebuild b/dev-php/cphplib/cphplib-0.51-r2.ebuild
new file mode 100644
index 000000000000..d40c6df8da76
--- /dev/null
+++ b/dev-php/cphplib/cphplib-0.51-r2.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Cute PHP Library (cphplib)"
+HOMEPAGE="http://cphplib.sourceforge.net/"
+SRC_URI="https://download.sourceforge.net/cphplib/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="dev-php/PEAR-DB"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}/${PN}-0.51-constructor.patch" )
+
+src_install() {
+ insinto "/usr/share/php/cphplib"
+ doins -r i18n cphplib_formular.inc cphplib.inc
+
+ docinto html
+ dodoc -r doc/.
+ einstalldocs
+}