summaryrefslogtreecommitdiff
path: root/dev-php/cli-prompt/cli-prompt-1.0.4.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-php/cli-prompt/cli-prompt-1.0.4.ebuild')
-rw-r--r--dev-php/cli-prompt/cli-prompt-1.0.4.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-php/cli-prompt/cli-prompt-1.0.4.ebuild b/dev-php/cli-prompt/cli-prompt-1.0.4.ebuild
new file mode 100644
index 000000000000..b8798f413e98
--- /dev/null
+++ b/dev-php/cli-prompt/cli-prompt-1.0.4.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Allows you to prompt for user input on the command line"
+HOMEPAGE="https://github.com/Seldaek/cli-prompt"
+SRC_URI="https://github.com/Seldaek/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-lang/php:*
+ dev-php/fedora-autoloader"
+
+src_install() {
+ insinto "/usr/share/php/Seld/CliPrompt"
+ doins -r src/. "${FILESDIR}"/autoload.php
+ dodoc README.md
+}