summaryrefslogtreecommitdiff
path: root/dev-php/awl/awl-0.62.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-php/awl/awl-0.62.ebuild')
-rw-r--r--dev-php/awl/awl-0.62.ebuild41
1 files changed, 0 insertions, 41 deletions
diff --git a/dev-php/awl/awl-0.62.ebuild b/dev-php/awl/awl-0.62.ebuild
deleted file mode 100644
index 4e252e4d02c1..000000000000
--- a/dev-php/awl/awl-0.62.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-DESCRIPTION="Andrew McMillan's Web Libraries"
-HOMEPAGE="https://gitlab.com/davical-project/awl"
-SRC_URI="https://www.davical.org/downloads/${PN}_${PV}.orig.tar.xz -> ${P}.tar.xz"
-
-USE_PHP="php8.0"
-
-LICENSE="GPL-2 GPL-2+ GPL-3+ LGPL-2+ LGPL-3+"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-BDEPEND="test? ( dev-php/phpunit )"
-RDEPEND="dev-lang/php:*[pdo,xml]"
-
-S="${WORKDIR}"
-
-src_compile() {
- :
-}
-
-src_test() {
- local slot
- for slot in ${USE_PHP//-/.} ; do
- if [[ -x /usr/bin/${slot} ]] ; then
- ${slot} "${EPREFIX}"/usr/bin/phpunit --verbose --do-not-cache-result tests/ \
- || die "test suite failed"
- fi
- done
-}
-
-src_install() {
- einstalldocs
- insinto /usr/share/php/${PN}
- doins -r dba inc
-}