summaryrefslogtreecommitdiff
path: root/dev-php/PEAR-Text_CAPTCHA/PEAR-Text_CAPTCHA-1.0.2-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-php/PEAR-Text_CAPTCHA/PEAR-Text_CAPTCHA-1.0.2-r1.ebuild')
-rw-r--r--dev-php/PEAR-Text_CAPTCHA/PEAR-Text_CAPTCHA-1.0.2-r1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-php/PEAR-Text_CAPTCHA/PEAR-Text_CAPTCHA-1.0.2-r1.ebuild b/dev-php/PEAR-Text_CAPTCHA/PEAR-Text_CAPTCHA-1.0.2-r1.ebuild
new file mode 100644
index 000000000000..39b7c17d0abe
--- /dev/null
+++ b/dev-php/PEAR-Text_CAPTCHA/PEAR-Text_CAPTCHA-1.0.2-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit php-pear-r2
+
+DESCRIPTION="Generation of CAPTCHAs"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="minimal"
+
+RDEPEND="dev-php/PEAR-PEAR >=dev-lang/php-5.3:*[gd,truetype] >=dev-php/PEAR-Text_Password-1.1.1
+ !minimal? ( dev-php/PEAR-Numbers_Words
+ dev-php/PEAR-Text_Figlet
+ >=dev-php/PEAR-Image_Text-0.7.0 )"
+
+src_prepare() {
+ sed -i -e '/role="doc"/d' -e '/role="test"/d' "${WORKDIR}/package.xml" || die
+ eapply_user
+}
+
+src_install() {
+ local DOCS=( README )
+ php-pear-r2_src_install
+}