summaryrefslogtreecommitdiff
path: root/dev-php/PEAR-Net_Sieve/PEAR-Net_Sieve-1.5.2-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-php/PEAR-Net_Sieve/PEAR-Net_Sieve-1.5.2-r1.ebuild')
-rw-r--r--dev-php/PEAR-Net_Sieve/PEAR-Net_Sieve-1.5.2-r1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-php/PEAR-Net_Sieve/PEAR-Net_Sieve-1.5.2-r1.ebuild b/dev-php/PEAR-Net_Sieve/PEAR-Net_Sieve-1.5.2-r1.ebuild
new file mode 100644
index 000000000000..2d6a716f5d8c
--- /dev/null
+++ b/dev-php/PEAR-Net_Sieve/PEAR-Net_Sieve-1.5.2-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MY_PN="${PN/PEAR-/}"
+
+DESCRIPTION="An API for talking to sieve (RFC 3028) servers"
+HOMEPAGE="https://github.com/roundcube/${MY_PN}"
+SRC_URI="${HOMEPAGE}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 ~s390 ~sh sparc x86"
+IUSE="sasl"
+
+RDEPEND="dev-lang/php:*
+ dev-php/PEAR-PEAR
+ dev-php/PEAR-Net_Socket
+ sasl? ( dev-php/PEAR-Auth_SASL )"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+src_install() {
+ # Install into "Net" for backwards compatibility (that's where PEAR
+ # used to put things).
+ insinto /usr/share/php/Net
+ doins Sieve.php
+}