summaryrefslogtreecommitdiff
path: root/dev-php/PEAR-MDB2/PEAR-MDB2-2.5.0_beta5-r3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-php/PEAR-MDB2/PEAR-MDB2-2.5.0_beta5-r3.ebuild')
-rw-r--r--dev-php/PEAR-MDB2/PEAR-MDB2-2.5.0_beta5-r3.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-php/PEAR-MDB2/PEAR-MDB2-2.5.0_beta5-r3.ebuild b/dev-php/PEAR-MDB2/PEAR-MDB2-2.5.0_beta5-r3.ebuild
new file mode 100644
index 000000000000..43edc74a8488
--- /dev/null
+++ b/dev-php/PEAR-MDB2/PEAR-MDB2-2.5.0_beta5-r3.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PEAR_PV=${PV/_beta/b}
+
+inherit php-pear-r2
+
+DESCRIPTION="Database Abstraction Layer"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE="mssql mysql mysqli postgres sqlite"
+
+RDEPEND="dev-php/PEAR-PEAR"
+
+PDEPEND="mssql? ( dev-php/PEAR-MDB2_Driver_mssql )
+ mysql? ( dev-php/PEAR-MDB2_Driver_mysqli )
+ mysqli? ( dev-php/PEAR-MDB2_Driver_mysqli )
+ postgres? ( dev-php/PEAR-MDB2_Driver_pgsql )"
+
+DOCS=( docs/{CONTRIBUTORS,MAINTAINERS,README,STATUS,TODO} )
+HTML_DOCS=( docs/datatypes.html )