summaryrefslogtreecommitdiff
path: root/dev-php/PEAR-Console_Table/PEAR-Console_Table-1.3.1-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-php/PEAR-Console_Table/PEAR-Console_Table-1.3.1-r1.ebuild')
-rw-r--r--dev-php/PEAR-Console_Table/PEAR-Console_Table-1.3.1-r1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-php/PEAR-Console_Table/PEAR-Console_Table-1.3.1-r1.ebuild b/dev-php/PEAR-Console_Table/PEAR-Console_Table-1.3.1-r1.ebuild
new file mode 100644
index 000000000000..2e39a052a20f
--- /dev/null
+++ b/dev-php/PEAR-Console_Table/PEAR-Console_Table-1.3.1-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit php-pear-r2
+
+DESCRIPTION="Class that makes it easy to build console style tables"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc64 ~sparc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+BDEPEND="test? ( dev-php/pear )"
+
+PATCHES=( "${FILESDIR}/fromArray-is-static.patch" )
+
+src_install() {
+ insinto /usr/share/php/Console
+ doins Table.php
+ php-pear-r2_install_packagexml
+}
+
+src_test() {
+ pear run-tests tests || die "Tests failed"
+}