summaryrefslogtreecommitdiff
path: root/dev-php/PEAR-Console_Getopt
diff options
context:
space:
mode:
Diffstat (limited to 'dev-php/PEAR-Console_Getopt')
-rw-r--r--dev-php/PEAR-Console_Getopt/Manifest3
-rw-r--r--dev-php/PEAR-Console_Getopt/PEAR-Console_Getopt-1.4.1-r1.ebuild26
-rw-r--r--dev-php/PEAR-Console_Getopt/metadata.xml11
3 files changed, 40 insertions, 0 deletions
diff --git a/dev-php/PEAR-Console_Getopt/Manifest b/dev-php/PEAR-Console_Getopt/Manifest
new file mode 100644
index 000000000000..49fc4d549afc
--- /dev/null
+++ b/dev-php/PEAR-Console_Getopt/Manifest
@@ -0,0 +1,3 @@
+DIST Console_Getopt-1.4.1.tgz 5580 BLAKE2B 514d44cfd2bb7c8bcda49df2b6ba4dafc77184557f58f52c02c6a136e335639e65b7c10f5659dad9d7a87e946d60947121cb5f35a72b6d29fbb3efa3e535283b SHA512 cbf12a72b33424935f019b17ae8fa55289eae77d3845dcfcbbc1c47b71111992d2c0eb837b0f262ce644809c3cc06ad0c2bb04aa1b6ec89a1e3122f327114dbd
+EBUILD PEAR-Console_Getopt-1.4.1-r1.ebuild 544 BLAKE2B e0cd02800d0a59cb5eb4a63725a4f8d7795b89b22cb5f695f0053c1d88c826a3280809ca7ed12abd959b62feae9a105a7a8f13c86d44342f0e8b7a094fd834d1 SHA512 7b7ed16bff52ff571a493a57cd520fe3376d5c34609d573e19bf9252759eeecb0e8ba3537dc180c779e6930afed92b9ee93c0a451ec035583068ec3354056187
+MISC metadata.xml 316 BLAKE2B 680f79e848a7196c2ab95b0be749c99b71dffeb3cfe501c57d8e6d84f0108e09e8e4e3d307e2db82ab7f65aeb4b3824bc801c29d7d0d8be14bb899c3557ccd65 SHA512 8103a2aac5f04ccca0accc1b5dcfc11ee2c59992ea7364e87cf1208fda18f58ac48c833413db682993464912087df6bae19419b153fdf335ea56a1ae406c5994
diff --git a/dev-php/PEAR-Console_Getopt/PEAR-Console_Getopt-1.4.1-r1.ebuild b/dev-php/PEAR-Console_Getopt/PEAR-Console_Getopt-1.4.1-r1.ebuild
new file mode 100644
index 000000000000..1d230653c536
--- /dev/null
+++ b/dev-php/PEAR-Console_Getopt/PEAR-Console_Getopt-1.4.1-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MY_PN="${PN/PEAR-/}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Command-line option parser"
+HOMEPAGE="http://pear.php.net/package/${MY_PN}"
+SRC_URI="http://pear.php.net/get/${MY_P}.tgz"
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 ~s390 ~sh sparc x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="dev-lang/php:*"
+PDEPEND="dev-php/PEAR-PEAR"
+
+S="${WORKDIR}/${MY_P}"
+
+src_install() {
+ insinto /usr/share/php
+ doins -r Console
+}
diff --git a/dev-php/PEAR-Console_Getopt/metadata.xml b/dev-php/PEAR-Console_Getopt/metadata.xml
new file mode 100644
index 000000000000..c8c9c843b99e
--- /dev/null
+++ b/dev-php/PEAR-Console_Getopt/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>php-bugs@gentoo.org</email>
+ <name>PHP</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pear">Console_Getopt</remote-id>
+ </upstream>
+</pkgmetadata>