summaryrefslogtreecommitdiff
path: root/dev-perl/Wx/Wx-0.993.200-r3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/Wx/Wx-0.993.200-r3.ebuild')
-rw-r--r--dev-perl/Wx/Wx-0.993.200-r3.ebuild11
1 files changed, 9 insertions, 2 deletions
diff --git a/dev-perl/Wx/Wx-0.993.200-r3.ebuild b/dev-perl/Wx/Wx-0.993.200-r3.ebuild
index 9c2559675aa1..abf2f39974bc 100644
--- a/dev-perl/Wx/Wx-0.993.200-r3.ebuild
+++ b/dev-perl/Wx/Wx-0.993.200-r3.ebuild
@@ -7,7 +7,7 @@ WX_GTK_VER="3.2-gtk3"
DIST_AUTHOR=MDOOTSON
DIST_VERSION=0.9932
DIST_EXAMPLES=("samples/*")
-inherit wxwidgets virtualx perl-module
+inherit toolchain-funcs wxwidgets virtualx perl-module
DESCRIPTION="Perl bindings for wxGTK"
HOMEPAGE="https://wxperl.sourceforge.net/ https://metacpan.org/release/Wx"
@@ -50,10 +50,17 @@ src_prepare() {
dos2unix MANIFEST || die
dos2unix typemap || die
- setup-wxwidgets
perl-module_src_prepare
}
+src_configure() {
+ # xspp sets CC to a c++ compiler but the eclass overrides it
+ # https://bugs.gentoo.org/931939
+ export CC="$(tc-getCXX)"
+ setup-wxwidgets
+ perl-module_src_configure
+}
+
src_test() {
# the webview/t/03_threads.t test tends to hang or crash in weird
# ways depending on local configuration. eg, backtraces involving