summaryrefslogtreecommitdiff
path: root/dev-perl/Wx-GLCanvas/Wx-GLCanvas-0.90.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/Wx-GLCanvas/Wx-GLCanvas-0.90.0.ebuild')
-rw-r--r--dev-perl/Wx-GLCanvas/Wx-GLCanvas-0.90.0.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-perl/Wx-GLCanvas/Wx-GLCanvas-0.90.0.ebuild b/dev-perl/Wx-GLCanvas/Wx-GLCanvas-0.90.0.ebuild
new file mode 100644
index 000000000000..9636d5033982
--- /dev/null
+++ b/dev-perl/Wx-GLCanvas/Wx-GLCanvas-0.90.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=MBARBON
+DIST_VERSION=0.09
+inherit perl-module virtualx
+
+DESCRIPTION="interface to wxWidgets' OpenGL canvas"
+
+SLOT="0"
+KEYWORDS="~amd64 x86"
+IUSE=""
+
+RDEPEND="
+ dev-perl/OpenGL
+ dev-perl/Alien-wxWidgets[opengl]
+ >=dev-perl/Wx-0.570.0
+"
+DEPEND="${RDEPEND}
+ virtual/perl-Exporter
+ virtual/perl-ExtUtils-MakeMaker
+"
+
+src_test() {
+ perl_rm_files "t/zz_pod.t"
+ virtx perl-module_src_test
+}