summaryrefslogtreecommitdiff
path: root/dev-perl/WWW-Bugzilla/WWW-Bugzilla-1.500.0-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/WWW-Bugzilla/WWW-Bugzilla-1.500.0-r2.ebuild')
-rw-r--r--dev-perl/WWW-Bugzilla/WWW-Bugzilla-1.500.0-r2.ebuild50
1 files changed, 0 insertions, 50 deletions
diff --git a/dev-perl/WWW-Bugzilla/WWW-Bugzilla-1.500.0-r2.ebuild b/dev-perl/WWW-Bugzilla/WWW-Bugzilla-1.500.0-r2.ebuild
deleted file mode 100644
index b860738c147c..000000000000
--- a/dev-perl/WWW-Bugzilla/WWW-Bugzilla-1.500.0-r2.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-DIST_AUTHOR=BMC
-DIST_VERSION=1.5
-inherit perl-module
-
-DESCRIPTION="Automate interaction with bugzilla"
-
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE=""
-
-RDEPEND=">=dev-perl/WWW-Mechanize-1.300.0
- >=dev-perl/Params-Validate-0.880.0
- >=dev-perl/Crypt-SSLeay-0.570.0
- >=dev-perl/Class-MethodMaker-1.80.0"
-DEPEND="${RDEPEND}"
-
-src_prepare() {
- perl-module_src_prepare
- mkdir "${S}"/lib || die "Can't mkdir lib"
- cp -r "${S}"/{WWW,lib} || die "Can't copy WWW"
-}
-
-# Network tests are broken
-DIST_TEST="skip"
-src_test() {
- local MODULES=(
- "WWW::Bugzilla ${DIST_VERSION}"
- "WWW::Bugzilla::Search 0.1"
- )
- local failed=()
- for dep in "${MODULES[@]}"; do
- ebegin "Compile testing ${dep}"
- perl -Mblib="${S}" -M"${dep} ()" -e1
- eend $? || failed+=( "$dep" )
- done
- if [[ ${failed[@]} ]]; then
- echo
- eerror "One or more modules failed compile:";
- for dep in "${failed[@]}"; do
- eerror " ${dep}"
- done
- die "Failing due to module compilation errors";
- fi
- perl-module_src_test
-}