summaryrefslogtreecommitdiff
path: root/dev-perl/Variable-Magic/Variable-Magic-0.610.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/Variable-Magic/Variable-Magic-0.610.0.ebuild')
-rw-r--r--dev-perl/Variable-Magic/Variable-Magic-0.610.0.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-perl/Variable-Magic/Variable-Magic-0.610.0.ebuild b/dev-perl/Variable-Magic/Variable-Magic-0.610.0.ebuild
new file mode 100644
index 000000000000..7162daef49cf
--- /dev/null
+++ b/dev-perl/Variable-Magic/Variable-Magic-0.610.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=VPIT
+DIST_VERSION=0.61
+DIST_EXAMPLES=("samples/*")
+inherit perl-module
+
+DESCRIPTION="Associate user-defined magic to variables from Perl"
+
+SLOT="0"
+KEYWORDS="~alpha amd64 ~arm ~arm64 hppa ~ia64 ppc ppc64 ~sparc x86 ~ppc-aix ~x86-fbsd ~x64-macos"
+IUSE="test"
+
+RDEPEND="
+ virtual/perl-Carp
+ virtual/perl-Exporter
+ virtual/perl-XSLoader
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ virtual/perl-Test-Simple
+ )
+"