summaryrefslogtreecommitdiff
path: root/dev-perl/Unicode-Map8
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/Unicode-Map8')
-rw-r--r--dev-perl/Unicode-Map8/Manifest2
-rw-r--r--dev-perl/Unicode-Map8/Unicode-Map8-0.130.0-r3.ebuild22
-rw-r--r--dev-perl/Unicode-Map8/files/Unicode-Map8-0.130.0-c99.patch48
3 files changed, 72 insertions, 0 deletions
diff --git a/dev-perl/Unicode-Map8/Manifest b/dev-perl/Unicode-Map8/Manifest
index b125bfa611ab..e0b623b66c96 100644
--- a/dev-perl/Unicode-Map8/Manifest
+++ b/dev-perl/Unicode-Map8/Manifest
@@ -1,3 +1,5 @@
+AUX Unicode-Map8-0.130.0-c99.patch 1090 BLAKE2B c9c9f500a2ffd6bf2cd17679821be1feb4c9f441c9bc28476a63c4247ad975cc37a1ee211c1b590b873755ad92bd965d70a73fd398504e74aa3c173b73678d68 SHA512 1aa38c720fc159a94e77e21d5f1b121e61ffe7a8be807bef57c2d3b86839dee905992e2c683608fd1024b51326379fa80d79a8582534cf9e2a3a6d7cc5f67f34
DIST Unicode-Map8-0.13.tar.gz 99250 BLAKE2B 675e39d091c41c2e92e279ada53c2b18283aa5416efc931eba67534af02fab196151e55757ebc689fc26840d290fa54ed91a77c588f8534d5ebe2ed0379ce42e SHA512 1e8db5bb1e10f13da4eb2c5de36d38e1cad5eeed2aba7e6bfcfb36cde727d557902ac476f64d28937ff2a53992c67f027d1a42edb005292d1c2ec89d05e18f2a
EBUILD Unicode-Map8-0.130.0-r2.ebuild 370 BLAKE2B 34efaddf73df7b9d59ee68c447b011aceb934aa8ffbc366cd0ff73eaede12ba13aeefa2dc66253131a1c68f269c1e24e15731d8f46407f65dc5e883f4bc4ae12 SHA512 4b5816a83beb0b6c72db62283ceae14676549f21e37f13262e2cb8713943823e9cb7f7f37c374d2cbf96ef907856eb795b3eaa3e6510e4c1504191c6cee322e1
+EBUILD Unicode-Map8-0.130.0-r3.ebuild 427 BLAKE2B 451fc2a5b40375443ac83c29e8fbf4f0eba7373ec3682823cacd2b75176a886a44b87dab1c84d1ccad35547c3f31073d4b37fbd4e80e4c4a4d5a090ba06890a7 SHA512 dcec356c8a3b26582a899eb98362ba2686abbe4f27877370cfa0034838ac35c2f039af26121b4935359a0a83f12c697193a1a113909cf462dca1a12e278cd0e2
MISC metadata.xml 397 BLAKE2B 35a70d53e492b84efb60b06ea34af4ab513049c619b8e05aaba51a5754a96f90f2dcbe48fb0cab15eb8598c46c4bf2df0d28534042b718cbc194953f529d588e SHA512 e820b1784470ae364ea6bdbbaf29aea3f95bbb12a62c082412086218e5955847d39c206ac1244df8c68774cc0c450c833c14d7cf2b6f212393d40bbf2708b785
diff --git a/dev-perl/Unicode-Map8/Unicode-Map8-0.130.0-r3.ebuild b/dev-perl/Unicode-Map8/Unicode-Map8-0.130.0-r3.ebuild
new file mode 100644
index 000000000000..54b99dcb0732
--- /dev/null
+++ b/dev-perl/Unicode-Map8/Unicode-Map8-0.130.0-r3.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_AUTHOR=GAAS
+DIST_VERSION=0.13
+inherit perl-module
+
+DESCRIPTION="Convert between most 8bit encodings"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-perl/Unicode-String-2.60.0
+"
+BDEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.130.0-c99.patch
+)
diff --git a/dev-perl/Unicode-Map8/files/Unicode-Map8-0.130.0-c99.patch b/dev-perl/Unicode-Map8/files/Unicode-Map8-0.130.0-c99.patch
new file mode 100644
index 000000000000..7305438159c4
--- /dev/null
+++ b/dev-perl/Unicode-Map8/files/Unicode-Map8-0.130.0-c99.patch
@@ -0,0 +1,48 @@
+https://bugs.gentoo.org/834518
+https://bugs.gentoo.org/856574
+https://bugs.gentoo.org/883709
+
+https://rt.cpan.org/Ticket/Display.html?id=24652
+https://rt.cpan.org/Ticket/Display.html?id=126031
+https://rt.cpan.org/Ticket/Display.html?id=70534
+https://rt.cpan.org/Ticket/Display.html?id=43404
+--- a/Map8.xs
++++ b/Map8.xs
+@@ -218,7 +218,7 @@ map8_to_char8(map, uc)
+ U16 uc
+
+ SV*
+-to8(map, str16)
++to8(map, xstr16)
+ Map8* map
+ PREINIT:
+ STRLEN len;
+@@ -282,7 +282,7 @@ to8(map, str16)
+ RETVAL
+
+ SV*
+-to16(map, str8)
++to16(map, xstr8)
+ Map8* map
+ PREINIT:
+ STRLEN len;
+@@ -347,7 +347,7 @@ recode8(m1, m2, str)
+ Map8* m2
+ PREINIT:
+ STRLEN len;
+- STRLEN rlen;
++ int rlen;
+ char* res;
+ INPUT:
+ char* str = SvPV(ST(2), len);
+--- a/map8.h
++++ b/map8.h
+@@ -80,7 +80,7 @@ void map8_free(Map8*);
+
+ U16* map8_to_str16(Map8*, U8*, U16*, int, int*);
+ U8* map8_to_str8 (Map8*, U16*, U8*, int, int*);
+-U8* map8_recode_8(Map8*, Map8*, U8*, U8*, int, int*);
++U8* map8_recode8(Map8*, Map8*, U8*, U8*, int, int*);
+
+ int map8_empty_block(Map8*, U8);
+