summaryrefslogtreecommitdiff
path: root/dev-perl/USB-LibUSB/USB-LibUSB-0.90.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/USB-LibUSB/USB-LibUSB-0.90.0.ebuild')
-rw-r--r--dev-perl/USB-LibUSB/USB-LibUSB-0.90.0.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-perl/USB-LibUSB/USB-LibUSB-0.90.0.ebuild b/dev-perl/USB-LibUSB/USB-LibUSB-0.90.0.ebuild
new file mode 100644
index 000000000000..e580e5fedc1c
--- /dev/null
+++ b/dev-perl/USB-LibUSB/USB-LibUSB-0.90.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_VERSION=0.09
+DIST_AUTHOR=AMBA
+KEYWORDS="~amd64 ~x86"
+inherit perl-module
+
+DESCRIPTION="Perl interface to the libusb-1.0 API"
+
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ virtual/libusb:1
+ virtual/perl-Carp
+ virtual/perl-Exporter
+ dev-perl/Moo
+ virtual/perl-XSLoader
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? ( virtual/perl-Test-Simple )
+"