summaryrefslogtreecommitdiff
path: root/dev-perl/Time-Out/Time-Out-0.240.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/Time-Out/Time-Out-0.240.0.ebuild')
-rw-r--r--dev-perl/Time-Out/Time-Out-0.240.0.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-perl/Time-Out/Time-Out-0.240.0.ebuild b/dev-perl/Time-Out/Time-Out-0.240.0.ebuild
new file mode 100644
index 000000000000..edb5afa51af9
--- /dev/null
+++ b/dev-perl/Time-Out/Time-Out-0.240.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_AUTHOR=SVW
+DIST_VERSION=0.24
+inherit perl-module
+
+DESCRIPTION="Easily timeout long running operations"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-perl/Try-Tiny
+"
+BDEPEND="
+ ${RDEPEND}
+ >=dev-perl/ExtUtils-MakeMaker-CPANfile-0.90.0
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ dev-perl/Test-Fatal
+ dev-perl/Test-Needs
+ )
+"
+
+PERL_RM_FILES=( "t/pod.t" )