summaryrefslogtreecommitdiff
path: root/dev-perl/Time-Moment/files/0.38-makefilepl.patch
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/Time-Moment/files/0.38-makefilepl.patch')
-rw-r--r--dev-perl/Time-Moment/files/0.38-makefilepl.patch34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-perl/Time-Moment/files/0.38-makefilepl.patch b/dev-perl/Time-Moment/files/0.38-makefilepl.patch
new file mode 100644
index 000000000000..b19e402df94a
--- /dev/null
+++ b/dev-perl/Time-Moment/files/0.38-makefilepl.patch
@@ -0,0 +1,34 @@
+diff -Naur Time-Moment-0.38/Makefile.PL Time-Moment-0.38b/Makefile.PL
+--- Time-Moment-0.38/Makefile.PL 2015-10-09 11:44:58.000000000 +0000
++++ Time-Moment-0.38b/Makefile.PL 2016-02-28 10:29:46.187136188 +0000
+@@ -3,27 +3,10 @@
+
+ BEGIN {
+ unshift @INC, 'inc';
+-
+- my @required = (
+- 'inc::Module::Install' => '1.00',
+- 'Module::Install::XSUtil' => '0.36',
+- 'Module::Install::ReadmeFromPod' => '0',
+- );
+-
+- my @missing;
+- while(my($module, $version) = splice(@required, 0, 2)) {
+- eval qq{use $module $version (); 1}
+- or push @missing, $module;
+- }
+-
+- if(@missing) {
+- print qq{# The following modules are not available.\n};
+- print qq{# `perl $0 | cpanm` will install them:\n};
+- s/\A inc:: //x for @missing;
+- print $_, "\n" for @missing;
+- exit 1;
+- }
+ }
++use inc::Module::Install 1.00 ();
++use Module::Install::XSUtil 0.36 ();
++use Module::Install::ReadmeFromPod 0 ();
+
+ use inc::Module::Install;
+