summaryrefslogtreecommitdiff
path: root/dev-perl/Time-Format/Time-Format-1.120.0-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/Time-Format/Time-Format-1.120.0-r1.ebuild')
-rw-r--r--dev-perl/Time-Format/Time-Format-1.120.0-r1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-perl/Time-Format/Time-Format-1.120.0-r1.ebuild b/dev-perl/Time-Format/Time-Format-1.120.0-r1.ebuild
new file mode 100644
index 000000000000..a42be47c6766
--- /dev/null
+++ b/dev-perl/Time-Format/Time-Format-1.120.0-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+DIST_AUTHOR=ROODE
+DIST_VERSION=1.12
+inherit perl-module
+
+DESCRIPTION="Easy-to-use date/time formatting"
+LICENSE="Time-Format"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="test"
+
+RDEPEND="
+ dev-perl/Date-Manip
+ >=virtual/perl-Time-Local-1.70.0
+"
+DEPEND="${RDEPEND}
+ >=dev-perl/Module-Build-0.400.0
+ test? ( >=virtual/perl-Test-Simple-0.400.0 )
+"
+PATCHES=(
+ "${FILESDIR}/${PN}-1.12-datetimetest.patch"
+ "${FILESDIR}/${PN}-1.12-nosig.patch"
+)
+PERL_RM_FILES=( "t/0-signature.t" "SIGNATURE" )
+
+src_configure() {
+ export TZ=UTC # https://rt.cpan.org/Public/Bug/Display.html?id=85001
+ perl-module_src_configure
+}