summaryrefslogtreecommitdiff
path: root/dev-perl/Text-Password-Pronounceable/Text-Password-Pronounceable-0.300.0-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/Text-Password-Pronounceable/Text-Password-Pronounceable-0.300.0-r1.ebuild')
-rw-r--r--dev-perl/Text-Password-Pronounceable/Text-Password-Pronounceable-0.300.0-r1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-perl/Text-Password-Pronounceable/Text-Password-Pronounceable-0.300.0-r1.ebuild b/dev-perl/Text-Password-Pronounceable/Text-Password-Pronounceable-0.300.0-r1.ebuild
new file mode 100644
index 000000000000..8a34a4c2d3cc
--- /dev/null
+++ b/dev-perl/Text-Password-Pronounceable/Text-Password-Pronounceable-0.300.0-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+MODULE_VERSION=0.30
+MODULE_AUTHOR=TSIBLEY
+inherit perl-module
+
+DESCRIPTION="Generate pronounceable passwords"
+
+SLOT="0"
+KEYWORDS="amd64 ~x86"
+IUSE="test"
+
+DEPEND="test? ( virtual/perl-Test-Simple )"
+
+SRC_TEST="do"
+
+src_prepare() {
+ sed -i -e 's/use inc::Module::Install;/use lib q[.]; use inc::Module::Install;/' Makefile.PL ||
+ die "Can't patch Makefile.PL for 5.26 dot-in-inc"
+ perl-module_src_prepare
+}
+
+src_test() {
+ perl_rm_files t/99pod.t t/99pod-coverage.t
+ perl-module_src_test
+}